Delays are observed when Enterprise Vault Search (EVS) page attempts to load.

Delays are observed when Enterprise Vault Search (EVS) page attempts to load.

Article: 100014403
Last Published: 2014-12-15
Ratings: 0 0
Product(s): Enterprise Vault

Problem

In a multi-domain environment where child-domains reside over slow links, a delay is observed when Enterprise Vault Search (EVS) page attempts to load.

Error Message

In order to validate the behavior in question, a DTrace of process W3WP while recreating the behavior is necessary. See DTrace excerpt below:

13:06:07.009     [14736]    (w3wp)    <17952>    EV-L    {EVS.EN_US} before getting the display name for the user || User: FAKE-DOMAIN\evadmin
13:07:08.121     [14736]    (w3wp)    <17952>    EV-L    {EVS.EN_US} after getting the display name for the user || User: FAKE-DOMAIN\evadmin

Note: No errors are observed on screen, nor in Enterprise Vault Application Log.

In order to further isolate the behavior, a packet trace can be utilized, i.e., WireShark, or NetMon. See example below:

TCP:[SynReTransmit #2503] [Bad CheckSum]Flags=CE....S., SrcPort=27778, DstPort=LDAP(389), PayloadLen=0, Seq=3598088736, Ack=0, Win=8192 (Negotiating scale factor 0x8 ) = 8192    {TCP:143, IPv4:95}

 

Cause

In order to obtain the 'Display Name' attribute of the logged on user LDAP is utilized, and when in multi-domain environment all Domain Controllers will be contacted due to referral chasing option set to all. To date the below causes have been identified:

Cause 1: Port 389 is being blocked.
Cause 2: Child domains reside over slow links.

Solution

Solution 1:
Allow LDAP traffic between Enterprise Vault Server and or Domain Controllers in the environment.
 

Solution 2:
This issue has been addressed in the following release:
 
Enterprise Vault 12.1.1 Release
https://www.veritas.com/docs/000116523



 

 

References

Etrack : 3891621

Was this content helpful?