When using NetBackup for VMware, if BIOS UUIDs are not unique, results of VIP queries filtering on custom attributes may be unpredictable.

  • Article ID:100013386
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Problem

Document history:
July 28, 2014: Initial publication
November 10, 2014: Updated for fixed version release

If BIOS UUIDs are not unique across all vCenters that NetBackup has access to, results of VIP (Virtual Machine Intelligent Policy) queries when filtering on custom attributes may be unpredictable.  This can lead to unexpected results, up to and including data loss if backups are skipped.

Cause

NetBackup can use VMware custom attributes for VM client selection filters for backups (VIP queries). NetBackup caches custom attributes internally and the key used in the cache is the VM BIOS UUID. Under certain circumstances, the BIOS UUID may not be unique - for example, when a VM is cloned with the vCloud Director or a third-party application.

This may introduce a side effect in NetBackup that causes the custom attribute cache to contain a value for just one of several cloned VMs sharing the BIOS UUID.  As a result, VIP queries may return unexpected and unpredictable results.

Solution

The formal resolution for this issue (Etrack 3538410) is included in the following release:

  • NetBackup 7.6 Maintenance Release 4 (7.6.0.4)

NetBackup 7.6.0.4 is now available - download and README information can be found in the Related Article linked below.

In NetBackup 7.6.0.4, the cache changes to use Instance UUIDs, which are guaranteed to be unique.

Workaround:
Remove duplicate BIOS UUIDs from vSphere as described in this VMware Knowledge Base article:

Editing a virtual machine with a duplicate UUID.bios
 https://kb.vmware.com/kb/1002403

If this workaround is unfeasible, please contact Veritas technical support, referencing this document, to determine if alternate solutions are available.

Best Practices:
Veritas strongly recommends the following best practices
1. Always perform a full DR backup prior to making any changes to your environment.
2. Always make sure that your environment is running the latest version and patch level.
3. Perform periodic "test" restores.

Applies To

All versions of NetBackup for VMware where VIP queries are supported may be affected by this issue.  This support began in NetBackup for VMware 7.1 GA.

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