Error backing up a VMware virtual machine - The server could not be backed up . Ensure that the server is online, and that the the correct version of the Agent for Windows is installed.

Article: 100012403
Last Published: 2023-10-23
Ratings: 2 4
Product(s): Backup Exec

Problem

A backup of a VMware virtual machine fails with the error “A quiesced snapshot could not be created for the virtual machine”. The verify operation of the job may also fail with the error “Unable to attach to VMVCB:\\<logical path to virtual machine>”, and the final error in the Job completion status section of the job log is “0xe0009543 – Cannot get the configuration details of a VMware virtual machine.”

 

Error Message

Backup:

V-79-57344-38374 - A quiesced snapshot could not be created for the virtual machine (DC)datacenter(DC)\vm\folder\virtualmachine. Alternatively, a crash-consistent snapshot was created. It is recommended to have a quiesced snapshot of a VM to ensure data consistency of the file system and all VSS-supported applications.

V-79-57344-34009 - An error was encountered creating on-disk catalog. If this is an incremental backup, cataloging of the generated media may not work correctly.

Verify:

Unable to attach to VMVCB::\\virtualcenter.domain.com\VCGuestVM\(DC)datacenter(DC)\vm\folder\virtualmachine.

V-79-57344-33899 - The server could not be backed up. Ensure that the server is online, and that the correct version of the Agent for Windows is installed.

 

Job Completion Status:

Final error: 0xe0009543 - Cannot get the configuration details of a VMware virtual machine.

 

Cause

This can occur if some part of the logical path to the virtual machine has changed since the backup job was created and the virtual machine was selected for backup. The logical path includes the datacenter name, the folder hierarchy, and the name of the virtual machine itself as it appears in the VCenter client. When the virtual machine is selected for backup, the backup selection entry includes the entire logical path to the machine. If any part of the path is renamed, or if the virtual machine is moved to a different location in the folder hierarchy, then the backup selection entry no longer points to the correct location in order to back up the virtual machine.

 

Solution

The backup selection entry for the virtual machine must be modified to select the machine from its current location. To do this, edit the backup definition and remove the existing selection, and then reselect the virtual machine from its new location.

1.       Select the backup definition from the Jobs list.

2.       Click Edit.

3.       In the backup selections panel on the left side of the Backup Definition Properties dialog box, click Edit.

4.       On the Selection Details tab, highlight the backup selection entry and then click Delete.

Note that the virtual machine itself may not be listed in the backup selections if the selection was made at a higher level in the folder hierarchy. Remove the most appropriate selection entry.

5.       On the Browse tab, expand the tree and select the virtual machine or folder from its new location.

6.       Click OK to save the backup selections.

7.       Click OK to save the backup definition with the new selections.

The backup sets created before the virtual machine name or folder hierarchy was changed can be restored, but the location to be restored must be redirected. When attempting to restore a virtual machine to its original location, the restore fails with the error "0xe000957e - Unable to create new virtual machine."

After editing a backup definition, the original folder hierarchy and virtual machines listed may appear on the Credentials page of the VCenter or ESX host in addition to the new folder hierarchy. After editing the backup selections, the original entries can be safely removed  from the list using Delete Selected button on the Credentials page.

References

UMI : V-79-57344-33899

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