Status 156 when performing Shadow Copy Component backups on cluster passive node

  • Article ID:100032982
  • Modified Date:
  • Product(s):

Problem

After upgrading to NetBackup 7.7.3, System State and/or Shadow Copy Component backups of the passive node of a cluster fails with status 156 due to unresolved volumes despite having run the command:

<install_path>\NetBackup\bin\W2KOption.exe -backup -ignore_unresolved_volumes <drive_letter>

Error Message

The following message may be seen in the Job Details:

Warning bpbrm (pid=10680) from client Client01: WRN - You have chosen to ignore unresolved volumes for Shadow Copy Components backups. Your backup will exit status zero even if the following volumes cannot be resolved H:

In the <install_path>\Veritas\NetBackup\logs\bpbkar log on the passive node the following error may be seen:

<snip>
12:59:44.780 [1324.2620] <2> ov_log::V_GlobalLog: INF - BEC System State flag set to TRUE, bSystemStateBackup = true
12:59:48.212 [1324.2620] <2> ov_log::V_GlobalLog: INF - Could not resolve volume path name for 'h:\program files\microsoft sql  server\mssql10_50.mssqlserver\mssql\binn' when getting file descriptors
12:59:50.294 [1324.2620] <2> ov_log::V_GlobalLog: INF - Informational status Unknown (0x00000003) returned calling FindFirstFile for
C:\Windows\System32\inetsrv\config\schema\* when getting additional files
<snip>
 

Cause

This is a regression that has been identified in NetBackup 7.7.3.  Prior versions of NetBackup (7.7.1 and 7.7.2) function correctly when using the W2KOption command detailed above.

Solution

Veritas Technologies LLC has acknowledged that the above-mentioned issue (Etrack 3898616) is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.  The formal resolution for this issue was scheduled to be included in the following release:
  • NetBackup 8.0

When NetBackup 8.0 is available, please access the following link for download and README information:
 https://www.veritas.com/content/support/en_US/15143.html

Please note that Veritas reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas' plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Workaround:
Download and apply the attached hotfix to all nodes in the cluster.

Hotfix information:

Veritas Bug ID: ET 3898614

Version:  NetBackup_7.7.3

Installation Location:  client

Installation Instructions: 
Please follow the EEB Installer instructions available on https://www.veritas.com/docs/000035801

Package Contents:
Please choose the appropriate platform after download:
eebinstaller.3898614.2.AMD64.exe  Windows x64 Installation
eebinstaller.3898614.2.x86.exe    Windows x86 Installation


Checksums:
1427470419 1860096 AMD64/bedsshadow.dll
4220525907 1613824 x86/bedsshadow.dll


Recommended service state: To ensure proper .dll replacement, all client services should be stopped before installing this EEB.

Downloads

Was this content helpful?

Get Support