LDAP Authentication appears to not function after a node restore.

Article: 100032968
Last Published: 2021-07-26
Ratings: 1 0
Product(s): eDiscovery Platform

Problem

A node backup taken from a previous version will restore completely.  The LDAP authentication is not available immediately after the restore because additional time is required to fully initialize.
 

Cause

LDAP authentication requires additional initialization time after a node restore.
 

Solution

How to determine when a node restore is complete:

1.
Perform node restore: do not exit.
Note: After the node restores completely, restart services

2. Monitor the .txt file that is generated for completion of the upgrade task. The file is named
esadb_<id>.txt, where <id> is an automatically generated file number. It is located under
<Project>/upgrade/reports/evidence_repo_<id>.

3. Locate PropertyUpgradeTask. Once the report displays " Upgrades Successful!", users will be able to login
via the LDAP credentials.


Example:
# 2016-07-31 16:15:22,973 Executing com.teneo.esa.common.util.PropertyUpgradeTask
.
.
# 2016-07-31 16:15:23,660 Upgrading: default.properties
# 2016-07-31 16:15:23,661 Applying script: Properties Upgrade.esa.ldap.connectionPassword to file:
D:\CW\V82\config\configs\default.properties
# 2016-07-31 16:15:23,664 Applying script: Properties Upgrade.esa.system.support.privilegedPassword to
file: D:\CW\V82\config\configs\default.properties
# 2016-07-31 16:15:23,760 Finished applying script: Properties Upgrade.esa.ldap.connectionPassword to
file: D:\CW\V82\config\configs\default.properties
# 2016-07-31 16:15:23,761 Finished applying script: Properties
Upgrade.esa.system.support.privilegedPassword to file: D:\CW\V82\config\configs\default.properties
# 2016-07-31 16:15:23,763 No changes in D:\CW\V82\config\configs\default.properties
# 2016-07-31 16:15:23,765 Upgrades successful!

References

JIRA : ESA-45036 JIRA : ESA-44773

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