Media frozen upon getting "Medium identifiers do not match" during backups when re-using barcode labels

Article: 100027311
Last Published: 2021-11-23
Ratings: 0 0
Product(s): NetBackup

Problem

Media frozen upon getting "Medium identifiers do not match" errors when re-using barcode labels on pre-loved (with expired images) or new media
 

Error Message

From bptm log :

22:22:28.896 [1768.8912] <4> manage_drive_attributes: expected manufacturer [FUJIFILM], reported [FUJIFILM]
22:22:28.896 [1768.8912] <4> manage_drive_attributes: expected serial number [AC3AE1GTE9], reported [AC3ACF7CR4]
22:22:28.974 [1768.8912] <16> manage_drive_attributes: FREEZING media id ABC123, Medium identifiers do not match
 

Cause

The EMM_Media record keeps track of the following medium identifier info :

ManufacturerName
SerialNumber

This information is updated to us by Hardware vendor.

 

LTO and SDLT are examples of technologies that report serial numbers of media. The BPTM log will include "medium manufacturer" along with a vendor name and serial number if your drives are reporting them. Sixteen byte CDB's are required to read this information from the drive.

The serial number can change if a new barcode label with same barcode is attached to the tape. This may limit us to use the tape with the serial number we have with us. This is a limitation from hardware side.

Solution

You can just delete the media ID from the Netbackup and run a inventory again. It should detect with new barcode.

Alternatively, you can label the medias to use them again:

1. Remove old media id to be re-used from Netbackup
2. Insert barcode label onto new tape/media
3. Perform robot inventory update (barcode rules may be required) to add new media id to Netbackup
4. If the new tape/media is actually a pre-loved Netbackup media, run bplabel command on this new media id to ensure it has the new media id recorded in its media header (See bplabel syntax for details)
5. The new media is now ready for use

Note: These steps can only help if the media is already expired.


 

 

Applies To

Netbackup 7.1.0.x on Windows platforms

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