Steps necessary when upgrading / updating Veritas Cluster Server on a clustered Veritas NetBackup 6.0 or NetBackup 5.x Server

  • Article ID:100017570
  • Modified Date:
  • Product(s):

Problem

Steps necessary when upgrading / updating Veritas Cluster Server on a clustered Veritas NetBackup 6.0 or NetBackup 5.x Server

Solution

Manual: Veritas NetBackup (tm) 6.0 High Availability Guide, Chapter 8 Configuring NetBackup
Modification Type:  Addition

Modification:
The following steps should be taken after upgrading VERITAS Cluster Server (VCS) software or after applying a Maintenance Update for VCS in a clustered NetBackup environment.

NetBackup uses the VCS ScriptAgent.  The new version of ScriptAgent needs to be copied to the /usr/openv/netbackup/bin/cluster/vcs directory after the cluster software is upgraded.  

Make sure the version of VCS software to which the nodes are getting upgraded is supported by NetBackup. This can be verified from the NetBackup 6.0 Cluster Compatibility guide:   https://www.veritas.com/support/en_US/article.000029917 . Once VCS is upgraded to the new version on all nodes, the following steps must be performed to update NetBackup.

1. Stop the NetBackupAgent:
# /opt/VRTSvcs/bin/haagent -stop NetBackup -sys <node1>
# /opt/VRTSvcs/bin/haagent -stop NetBackup -sys <node2>

2. On each node of the cluster,  run the following commands:
# cd /usr/openv/netbackup/bin/cluster/vcs
# cp NetBackupAgent NetBackupAgent.old
# cp /opt/VRTSvcs/bin/ScriptAgent NetBackupAgent

3. Start the NetBackupAgent
# /opt/VRTSvcs/bin/haagent -start NetBackup -sys <node1>
# /opt/VRTSvcs/bin/haagent -start NetBackup -sys <node2>
 
 

 

Related Articles

NetBackup (tm) 6.x Cluster Compatibility (Updated January 28 2010)

Was this content helpful?

Get Support