Problem
Backup jobs fail with status 84, job details show the following critical error from bptm - image open failed: error 2060017: system call failed
Error Message
Job detailed status:
0/00/0000 0:00:00 AM - Info bpbkar32(pid=0000) archive bit processing:<enabled>
0/00/0000 0:00:00 AM - Critical bptm(pid=0000) image open failed: error 2060017: system call failed
0/00/0000 0:00:00 AM - Info bpbkar32(pid=0000) INF - waiting for mount mutex
0/00/0000 0:00:00 AM - Info bptm(pid=0000) EXITING with status 84 <----------
0/00/0000 0:00:00 AM - Info bpbkar32(pid=0000) done. status: 84: media write error
0/00/0000 0:00:00 AM - end writing
media write error(84)
bptm.log
----------------
08:45:29.476 [0000.0000] <2> initialize: fd values STDOUTSOCK=304 STDERRSOCK=696
08:45:29.476 [0000.0000] <4> bptm: emmserver_name = master
08:45:29.476 [0000.0000] <4> bptm: emmserver_port = 1556
08:45:29.538 [0000.0000] <4> 631789:bptm:7384:media2: libsts setupp() 15/02/18 08:45:29: AdvancedDisk:media2 claimed by C:\Veritas\NetBackup\bin\\libstspibasicdisk.dll
08:45:29.538 [0000.0000] <4> 631789:bptm:7384:media2: libsts setupp() 15/02/18 08:45:29: AdvancedDisk:media2 claimed by C:\Veritas\NetBackup\bin\\libstspibasicdisk.dll
08:45:29.632 [0000.0000] <4> report_client: VBRC 2 7384 1 dag1_1424274311 16 2010_Storage_UNIT 0 Full 0 1 1
08:45:29.694 [0000.0000] <4> 631789:bptm:7384:media2: STSBasicDisk: LSU is Advanced Disk
08:45:29.710 [0000.0000] <4> 631789:bptm:7384:media2: STSBasicDisk: LSU is Advanced Disk
08:45:29.710 [0000.0000] <4> 631789:bptm:7384:media2: STSBasicDisk: LSU is Advanced Disk
08:45:29.804 [0000.0000] <4> write_disk_header: Data Classification & Storage Lifecycle action 4
08:45:29.804 [0000.0000] <16> 631789:bptm:7384:media2: STSImageManager: open() failed on image file \\Filer\exchange1\dag1_1424274311_C1_HDR.1424274311.info (Input/output error)
08:45:29.804 [0000.0000] <16> 631789:bptm:7384:media2: STSImageManager: Caught exception in STSIMGImageManager::CreateImage, FILE=STSIMGImageInfo.cpp, FUNCTION=STSIMGImageInfoHandle::STSIMGImageInfoHandle, LINE=1083, ERROR=STS_ESYS
08:45:29.804 [0000.0000] <32> bp_sts_open_image: sts_create_image failed: error 2060017
08:45:29.850 [0000.0000] <32> write_disk_header: image open failed: error 2060017:
08:45:47.120 [0000.0000] <2> initialize: fd values STDOUTSOCK=304 STDERRSOCK=692
Cause
By default, the NetBackup Client Service is configured on Windows with the Local System account. The Local System account lacks sufficient rights to perform certain backup and restore operations.
For example, for NetBackup to access NFS or CIFS volumes, the account must be changed from Local System to an account with access to the NFS/CIFS share.
Solution
1. Open the Windows Services application.
2. Open the properties for the NetBackup Client Service
3. Provide the name and password of the account that has the necessary permissions instead of the Local System account. For example, change the logon to that of Administrator.
3. Restart the NetBackup Client Service.
After the above procedure was done, backups started working without errors.
Applies To
Master Server 7.X
OS - Windows 2008 R2
NFS mounted filer