VMware backups failing with status 58 - can't connect to client

Article: 100015008
Last Published: 2015-02-02
Ratings: 2 2
Product(s): NetBackup & Alta Data Protection

Problem

All backups in one VMware policy are failing with Status 58

Error Message

01/29/2015 14:13:54 - Info bpbrm (pid=16460) connect failed STATUS (18) CONNECT_FAILED
01/29/2015 14:13:54 - Info bpbrm (pid=16460)     status: FAILED, (44) CONNECT_TIMEOUT; system: (115) Operation now in progress; FROM <ip_address> TO <backup host_name> <backup_host_IP_address> bpcd VIA pbx
01/29/2015 14:13:54 - Info bpbrm (pid=16460)     status: FAILED, (44) CONNECT_TIMEOUT; system: (115) Operation now in progress; FROM <ip_address> TO <backup host_name> <backup_host_IP_address> bpcd VIA vnetd
01/29/2015 14:13:54 - Info bpbrm (pid=16460)     status: FAILED, (44) CONNECT_TIMEOUT; system: (115) Operation now in progress; FROM <ip_address> TO <backup host_name> <backup_host_IP_address> bpcd
01/29/2015 14:13:54 - Error bpbrm (pid=16460) cannot connect to <backup_host_name>, Operation now in progress (115)
01/29/2015 14:13:54 - Info bpbkar (pid=0) done. status: 58: can't connect to client

Cause

A NetBackup VMware agent backup using the VMware policy type makes use of a NetBackup server identified as the VMware backup host. The VMware backup host is used as the proxy client for the purpose of backing up the virtual machines. In most cases there is no NetBackup client software installed in the virtual machines themselves, the exception being when the application protection for Exchange, SQL, or SharePoint is being used.

When using the VMware agent and the error "can't connect to client" is encountered this indicates a failure internal to NetBackup communications. This is not a failure between NetBackup and the VMware vCenter server, ESX hosts, or virtual machines.

In this specific case the NetBackup media server is separate from the NetBackup VMware backup host and the NetBackup media server is unable to reach the standard NetBackup ports on the NetBackup VMware backup hosts:

  • 1556 (pbx)
  • 13724 (vnetd)
  • 13782 (bpcd)

This can be due to one of the following reasons:

  1. The NetBackup media server is unable to reach the NetBackup VMware backup host over the network, i.e. ping fails:
    • Log into media server command-line.
    • Ping backup host by name fails:
      ping <backup_host>
  2. The NetBackup media server can ping the NetBackup VMware backup host, but cannot connect to the required ports:
    • Log into media server command-line.
    • Telnet to backup host port numbers fail:
      telnet <backup_host> 1556
      telnet <backup_host> 13724
      telnet <backup_host> 13782

Solution

  1. Make sure there is a network routable path from the NetBackup media server to the NetBackup VMware backup host.
  2. Make sure the media server can resolve the host name of the backup host to the correct IP address.
  3. Make sure the media server can successfully ping the backup host. 
  4. Make sure the media server can connect to the required NetBackup ports on the backup host:
    telnet <backup_host> 1556
    telnet <backup_host> 13724
    telnet <backup_host> 13782
    • Where:
      1556 (pbx TCP port)
      13724 (vnetd TCP port)
      13782 (bpcd TCP port)

Applies To

NetBackup VMware agent.

The backup host is a stand-alone NetBackup client, so separate from the NetBackup media server that will be writing backup images to storage unit.

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