Status 2820 and status 59 - access to the client was not allowed when restoring single file(s) from VMware backup image

Article: 100014869
Last Published: 2018-10-16
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

Unable to perform single file restore from VMware backup image of virtual machine with Windows guest operating system. Destination virtual machine has same guest operating system as original virtual machine. NetBackup client installed in destination virtual machine as required.

 

Error Message

From the Activity Monitor > Job Details:

1/13/2015 9:46:49 AM - granted resource MediaID=@aaaaf;DiskVolume=<volume_name>;DiskPool=<poolname>;Path=<volume_name>;StorageServer=<server_name>;MediaServer=nbmedia01.veritas.com
1/13/2015 9:54:40 AM - Info bpdm(pid=10496) completed reading backup image        
1/13/2015 9:54:53 AM - Error bpbrm(pid=5100) bpcd on <client_name> exited with status 59: access to the client was not allowed
1/13/2015 9:54:55 AM - Info tar32(pid=0) done. status: 59: access to the client was not allowed  
1/13/2015 9:54:55 AM - Error bpbrm(pid=5100) client restore EXIT STATUS 59: access to the client was not allowed
1/13/2015 10:06:45 AM - restored image <client_name>_1418884483 - (cannot connect on socket(25)); restore time 0:19:56
1/13/2015 10:06:53 AM - end Restore; elapsed time: 0:20:06
VMware policy restore error(2820)

 

Cause

When restoring single files from a virtual machine backup image a NetBackup client is required to be installed in the destination client, in this case the virtual machine. This is required even though the NetBackup client is not used during a VMware agent backup, nor is it used during a VMware full virtual machine restore.

When the restore is initiated both the master and the media server will connect to the client.  If the master is not in the client's NetBackup server list the restore will default to being a Windows client restore.  However, if the media server is not in the client's NetBackup server the restore will fail to be authorized resulting in the following error seen in the error block above:

1/13/2015 9:54:55 AM - Error bpbrm(pid=5100) client restore EXIT STATUS 59: access to the client was not allowed

From the same error block above, we see earlier the media server attempting the connection:

1/13/2015 9:46:49 AM - granted resource MediaID=@aaaaf;DiskVolume=<volume_name>;DiskPool=<pool_name>;Path=<volume_name>;StorageServer=<server_name>;MediaServer=nbmedia01.veritas.com

In this case, nbmedia01.veritas.com is the media server.

 

Solution

  1. Log in to the destination client.
  2. Open the destination clients "Backup, Archive and Restore" located under "Start -> All Programs -> Veritas NetBackup -> Backup, Archive and Restore."
  3. In the "Backup, Archive and Restore" menu bar, go to "File -> Specify NetBackup Machines and Policy Type"
  4. Click on "Edit Server List"
  5. In the "enter names to add to list (separated by commas):" field enter the media server name.
  6. Click "add Name(s)."
  7. If necessary add the name of the NetBackup master server.
  8. Click 'OK'
  9. Click 'OK'
  10. Close the "Backup, Archive and Restore" interface.
  11. Test the restore.

 

Notes:

If the error "EXIT STATUS 59" is still encountered...

  1. Create the following logging directory on the destination client:
    • UNIX/Linux: /usr/openv/netbackup/logs/bpcd
      Windows: install_path\NetBackup\logs\bpcd
  2. Try the restore and contact support with this log file for assistance.

Note: If the changes to the destination client's server list are not saving, launch the "Backup, Archive and Restore" application on the destination client by selecting the icon and doing a "Right-click, Run as administrator."  Sometimes this is due to the Microsoft Windows UAC and requires this additional step to open the application in write mode.

 

Applies To

NetBackup VMware backup host.
Windows guest operating system in virtual machine being restored to as the destination client.

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