VMware agent application protection backup fails with Status 47 - host is unreachable(47)

Article: 100014630
Last Published: 2014-12-03
Ratings: 1 1
Product(s): NetBackup & Alta Data Protection

Problem

With the application protection option unchecked in the NetBackup policy's VMware tab the backup is successful.  When using VMware agent with application protection the database portion of the backup is failing. The NetBackup client software is already installed in the virtual machine's guest operating system.

Error Message

Status 47

host is unreachable(47)

Cause

The following command executed on the backup host confirmed the backup host was unable to connect to the NetBackup client service (bpcd):

cd <install_path>\Veritas\NetBackup\bin\admincmd

bptestbpcd -client <virtual_machine_hostname>

This returned the following error:

<16>bptestbpcd main: Function ConnectToBPCD(virtual_machine_hostname) failed:
25
cannot connect on socket

Solution

Log in to the virtual machine's guest operating system and start NetBackup client services.

These will include the following, visible in Windows services -

NetBackup Client service
NetBackup Legacy client service
Veritas Private Branch Exchange

To stop and restart services:

1. Go to correct directory at command-line:

cd <install_path>\Veritas\NetBackup\bin

2.  Stop NetBackup services:

bpdown.exe -v

3. Confirm services stopped:

bpps

4.  Restart services:

bpup.exe -v

Check that the above NetBackup services remain started in Windows services.

If they go down, attempt to start each one manually.

If the following errors are encountered when trying to start these services in Windows services this may indicate  an issue with the account the service is logging in with. 

Error 1068: The dependency service or group failed to start.

Error 1069: The service did not start due to a logon failure.

If these errors are encountered confirm the username and password specified in the services "Log On" tab is correct.

 

Applies To

VMware virtual machine with Windows guest operating system.

NetBackup VMware agent with application protection option "Enable SQL Server Recovery" checked in the policy's VMware tab.

Confirmed NetBackup client software was installed in the virtual machine's guest operating system.

Confirmed the NetBackup VMware backup host was able to resolve and ping the client's hostname.

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