Backup Exec Remote Agent service fails to start and following error is displayed "Error 1053: The service did not respond to the start or control request in a timely fashion"

Article: 100011434
Last Published: 2017-12-04
Ratings: 1 1
Product(s): Backup Exec

Problem

Backup Exec Remote Agent service fails to start. "Error 1053: The service did not respond to the start or control request in a timely fashion".  Additionally, starting any executable process (like vxmon.exe) from %programfiles%\Symantec\Backup Exec\RAWS directory results in error mentioned below.

The Backup Exec error reporting service may not start which the Backup Exec remote agent is dependent on.

 

Error Message

Launching any exe from Backup Exec\RAWS directory results in a pop up error with following description:

The application was unable to start correctly (0xc000007b). Click OK to close the application.

 

Following event is logged in System Event Viewer on the server when trying to start the Remote Agent service:



---------------

Log Name:      System
Source:        Service Control Manager
Event ID:      7000
Task Category: None
Level:         Error
Keywords:      Classic

Description:
The Backup Exec Remote Agent for Windows service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion

---------------

Log Name:      System
Source:        Service Control Manager
Event ID:      7000
Task Category: None
Level:         Error
Keywords:      Classic

Description:
The Backup Exec Error Recording Service service failed to start due to the following error: 
The operation completed successfully. (0x0000041D)"


---------------

Log Name:      System
Source:        Service Control Manager
Event ID:      7009
Task Category: None
Level:         Error
Keywords:      Classic

Description:
A timeout was reached (30000 milliseconds) while waiting for the Backup Exec Error Recording Service service to connect.

---------------

 

Cause

A Microsoft runtime DLL in the system32 directory is for the wrong platform. This can be confirmed by running Dependency Walker on the Server for beremote.exe, vxmon.exe,, or bedbg.exe.   If there is a problem loading the runtimes then the result will show an error like below:

Solution

In the dependency walker example above, the msvcp100.dll failed to load since it is incorrectly a 32 bit version of the file in the 64 bit “%Windir%\System32” directory. To resolve this issue rename the msvcp100.dll in the %Windir%\System32 directory to msvcp100.dll.org and then install Microsoft Visual C++ 2010 Redistributable Package with latest Service Pack for 64 bit server. A repair of the Remote Agent for Windows Systems may also install the file.

 

 

 

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