Exchange 2010 Mailbox Archiving performance is degraded, producing Event IDs 3419 and 2217 and CAS errors

Article: 100005787
Last Published: 2020-09-25
Ratings: 0 0
Product(s): Enterprise Vault

Problem

The performance of Exchange 2010 Mailbox Archiving is degraded, producing numerous Event IDs 3419 and 2217 on the Enterprise Vault (EV) Server.
These events are accompanied by Event ID 2521 produced on the associated Exchange 2010 Client Access Server (CAS) Role(s), associated with the Vault Service Account (VSA).

Error Message

[Event log at Enterprise Vault Server]

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          1/1/2014 12:00:00 AM
Event ID:      3419
Task Category: Journal Task
Level:         Warning
Computer:      EVServer.domain.local
Description:
There was a problem accessing an Exchange 2010 or later server.  The dispenser will re-queue the current item and sleep for 1 minute(s).
Task: Exchange Journaling Task for Exchange 2010 Server
V-437-3419

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          1/1/2014 12:00:00 AM
Event ID:      2217
Task Category: Journal Task
Level:         Warning
Computer:      EVServer.domain.local
Description:
Message dispenser will resume processing
Task: Exchange Journaling Task for Exchange 2010 Server
V-437-2217

[Event log at Microsoft Exchange CAS Server]

Error 2011-03-23 2:30:18 PM MSExchange ADAccess 2915 Process  Microsoft.Exchange.RpcClientAccess.Service.exe(PID=4544). 'Sid~AUTOS\evadmin01~RCA~false' has gone over budget '128' times for component 'RCA' within a one minute period. Info:  'Policy:EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428, Information: 'Policy:EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428, Parts:CAS:5153;'. Threshold vaule: '100'.

[DTrace]

168 10:19:23.211  [5544] (JournalTask) <4612> EV:M CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x0
177 10:19:23.226  [5544] (JournalTask) <4612> EV:M CArchivingAgent::ProcessItemInternal - Call to PI_GetMAPISession Failed RetryCount[1] [0x8004011D]

Cause

In Enterprise Vault 9.0.1, the powershell script to configure the Enterprise Vault Throttling Policy (SetEVThrottlingPolicy.ps1) in the Exchange 2010 servers does not apply all the required settings and Enterprise Vault is throttled by other RCP throttling parameter.

Solution

In the Microsoft Exchange 2010 server, this issue can be confirmed running the following powershell command in the Exchange Management Shell:

[PS] C:\>Get-ThrottlingPolicy -Identity EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428 | fl name, rca*

Name                       : EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428
RCAMaxConcurrency          :
RCAPercentTimeInAD         : 5
RCAPercentTimeInCAS        : 205
RCAPercentTimeInMailboxRPC : 200

The output will show that only RCAMaxConcurrency parameter has been set with the correct value. This issue can be fixed with an additional throttling policy setting.  The following settings should be set to NULL for the Enterprise Vault Throttling policy: RCAPercentTimeInAD, RCAPercentTimeInCAS and RCAPercentTimeInMailboxRPC.
In the Exchange Management Shell for Exchange 2010 Server, run the following command:

[PS] C:\>Set-ThrottlingPolicy -Identity EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428 -RCAMaxConcurrency $null -RCAPercentTimeInAD $null -RCAPercentTimeInCAS $null -RCAPercentTimeInMailboxRPC $null

To confirm the newly set value(s), perform the following command:

[PS] C:\>Get-throttlingPolicy EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428

Once this value is updated, restart the Enterprise Vault Task Controller service, which will reset all the MAPI connections and use the updated throttling policy.


This issue has been addressed as part of the following release:

Enterprise Vault 9.0.2

 

Applies To

Microsoft Exchange 2010

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