bpbkar32.exe produces an Application Fault when backing up DFSR data

Article: 100004991
Last Published: 2011-04-20
Ratings: 0 0
Product(s): NetBackup

Problem

Windows 2008 or Windows 2008 R2 clients with DFSR data can encounter a situation which causes bpbkar32.exe to generate an application fault for the bpbkar32.exe process. This will cause the job to conclude in Activity Monitor with Status 13.

Error Message

Upon inspection, the Application Event Log on the client will show:

 

Sat Sep 18 2010 20:40:03 Application Error E1000 Faulting application name: bpbkar32.exe, version: 7.0.0.0, time stamp: 0x4c7694c0 
Faulting module name: bedsnt5.dll, version: 13.0.4163.0, time stamp: 0x4c29902d
Exception code: 0xc0000005
Fault offset: 0x000000000008666e
Faulting process id: 0x760
Faulting application start time: 0x01cb5798003c0145
Faulting application path: C:\Program Files\VERITAS\NetBackup\bin\bpbkar32.exe
Faulting module path: C:\Program Files\VERITAS\NetBackup\bin\bedsnt5.dll
 
If job retries are configured, the job will retry and may or may not succeed, failing with the same error.

 

Cause

This issue has been known to occur based on the order of which items are backed up.

Solution

As a workaround, it is possible to adjust the Policy Backup Selections and remove ALL_LOCAL_DRIVES in favor of a statically ordered list.  
For example:

C:\
System State:\
Shadow Copy Components:\System Services\
Shadow Copy Components:\User Data\

Note: DFSR content is backed up under "Shadow Copy Components:\User Data\".  It is important that User Data be listed LAST.  Also, to insure the greatest likelihood of success, make sure Allow Multiple Datastreams is unchecked on the Policy Attributes tab.

Solution:
Veritas acknowledges this is an issue and is on track to fix it in a future release or patch.

For NetBackup 7.1, a fix is included in the externally available EEB (Emergency Engineering Binary) bundle available in 000012714 (linked below).


References

Etrack : 2118052

Was this content helpful?