Getting error "error connecting to oprd on server xxx ,oprd returned abnormal status 96" when running the device configuration wizard

Article: 100002961
Last Published: 2012-01-10
Ratings: 1 0
Product(s): NetBackup & Alta Data Protection

Problem

Getting  error "error connecting to oprd on server xxx ,oprd returned abnormal status 96" when running the device configuration wizard.Also unable to expand the devices tab ,getting error  "error connecting to oprd,network protocol error 39"

Error Message

Error connecting to oprd on server xxx ,oprd returned abnormal status 96

Error connecting to oprd,network protocol error 39

Cause

Stale entries for deleted devices in the NetBackup EMM database.Or if a media server is not correctly decommissioned.

Solution

Step 1:

Windows only:

From command prompt run set devmgr_show_nonpresent_devices=1

Open the device manager click 'view' >show hidden devices > tape drives >check for ghost drives which are no longer connected to the server,if any remove them (repeat this for each media server)

Step 2:

Stop NetBackup services

Windows
<install_path>\NetBackup\bin bpdown -v -f

Unix
/usr/openv/netbackup/bin/goodies/netbackup stop

Rename the .lock file(s) in:

Windows
<Install_path> \Veritas\Volmgr\misc

UNIX
/usr/openv/volmgr/misc
 


Restart the NetBackup services
 

Windows
<install_path>\NetBackup\bin bpup -v -f

Unix
/usr/openv/netbackup/bin/goodies/netbackup start
 


Step 3:

On the master server run these commands

Windows
<Install_path>\Netbackup\bin\admincmd>nbemmcmd -deletealldevices -allrecords

UNIX
/usr/openv/netbackup/bin/admincmd/nbemmcmd -deletealldevices -allrecords

Windows
<Install_path>\Netbackup\bin\admincmd >nbrbutil -resetall

UNIX:
/usr/openv/netbackup/bin/admincmd/nbrbutil -resetall

This should take care of the error and we should be able to configure the devices


Applies To

Windows 2003, 2008

Was this content helpful?