Unable to connect to a NetBackup client. Exit Status 25 - cannot connect on socket.

  • Article ID:100002629
  • Modified Date:
  • Product(s):

Problem

Unable to connect to a NetBackup client.  Exit Status 25 - cannot connect on socket.  For example, if an attempt is made to connect to the client from the Host Properties tree in the NetBackup Administration Console.

Error Message

Exit Status 25 - cannot connect on socket.

Cause

Examine the bpcd log from the client for evidence of the following

10:44:50.087 [9501] <2> bpcd main: setup_sockopts complete
10:44:50.091 [9501] <8> bpcd peer_hostname: gethostbyaddr failed : HOST_NOT_FOUND (1)
10:44:50.091 [9501] <16> bpcd peer_hostname: gethostbyaddr failed to return peer host, herrno = 1
10:44:50.091 [9501] <16> bpcd main: Couldn't get peer hostname

Solution

This condition is indicative of a problem with host name resolution via either DNS or the hosts file.  Verify that the client's hostname resolves correctly to its IP address and that the reverse is true.  That is, that the IP address reverse lookup corresponds to the client's hostname.

Perform this verification on both the client and the master server.


Was this content helpful?

Get Support