Local Installation of the Remote Agent for Windows Systems (RAWS) fails with "The return code from the MSI is: 2"

Article: 100001886
Last Published: 2020-08-28
Ratings: 1 1
Product(s): Backup Exec

Problem

Local Installation of the Remote Agent for Windows Systems (RAWS) fails with "The return code from the MSI is: 2"

Error Message

The return code from the MSI is: 2

When performing a local installation of Remote Agent for Windows Systems (RAWS) will see the following in the RAWSINST.HTM
NOTE: RAWSINST.HTM is located at (C:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec\Logs)

NEWER VERSIONS OF BACKUP EXEC:
In more current versions of Backup Exec the installation log file is called RAWSINSTxx.HTM
(xx represents the Backup Exec version number; example RAWSINST20.HTM)
The RAWSINSTxx.HTM file is located under C:\ProgramData\Veritas|Backup Exec\Logs

05-18-2010,08:58:05 : Explorer exists. Launching UI.
05-18-2010,08:58:07 : Executing managed _Setup:
05-18-2010,08:58:07 : D:\techsupport\RAWS32\install\_Setup.exe
05-18-2010,08:58:12 : Loading XML from:
05-18-2010,08:58:12 : D:\techsupport\RAWS32\install\IFProducts.xml
05-18-2010,08:58:12 : ArgsDataParser::InitDictionary
05-18-2010,08:58:12 : AgentSeqDlgs::RawsDlgSequence
05-18-2010,08:58:12 : Set Remote Agent for Windows Systems Media path: D:\techsupport\RAWS32\install\media\
05-18-2010,08:58:12 : RawsDlgSequence::CheckInstMode
05-18-2010,08:58:12 : BEOperations::BE_GetInstalledProdCodeVersion
05-18-2010,08:58:19 : BEOperations::BE_GetInstalledProdCodeVersion
05-18-2010,08:58:20 : Launching UI Install
05-18-2010,08:58:20 : Running in Installation mode
05-18-2010,08:58:20 : AgentSeqDlgs::ADlgWelcome
05-18-2010,08:58:20 : AgentSeqDlgs::ADlgInstallType
05-18-2010,08:58:20 : RawsDlgSequence::CheckInstalledProducts
05-18-2010,08:58:20 : BEOperations::BE_GetInstalledProdCodeVersion
05-18-2010,08:58:20 : BEOperations::BE_GetInstalledProdCodeVersion
05-18-2010,08:58:20 : AgentSeqDlgs::DlgChooseCustom
05-18-2010,08:58:21 : AgentSeqDlgs::ADlgPublishRemoteSrv
05-18-2010,08:58:21 : AgentSeqDlgs::AdlgInstallComplete
05-18-2010,08:58:22 : AgentSeqDlgs::Misc_BE_CommonOps
05-18-2010,08:58:27 : Local Install Agent
05-18-2010,08:58:35 : AgentSeqDlgs::ReadAdvertiseListKey
05-18-2010,08:58:45 : AgentSeqDlgs::ReadAdvertiseListKey
05-18-2010,08:58:45 : 192.168.34.10;
05-18-2010,08:58:49 : AgentSeqDlgs::AgentInstaller
05-18-2010,08:58:49 : Starting Install
05-18-2010,08:58:50 : Remote Agent for Windows Systems MSI Command Line: EXE_ENVOKED=1 ALLUSERS=1 REBOOT=ReallySuppress INSTALLDIR="d:\Program Files\Symantec\Backup Exec\RAWS" INSTALLLEVEL=100 ADDLOCAL=VFF,VSSPROV,RANT TRANSFORMS="C:\WINDOWS\Installer\{B7C50B9F-8463-45A5-A2C9-33DA83E42F99}\1033.MST" RAWSADVRTISENAMELIST=192.168.34.10; ENABLEADVRT=1 PATCH="D:\techsupport\RAWS32\Updates\RAWS322896RHF340433.msp;" VMWAREGUEST = 0 INSTALLUIMODE=1
05-18-2010,08:58:50 : Running Install Mode
05-18-2010,08:58:50 : AgentInstaller::Install_Product_Thread
05-18-2010,08:58:50 : Launching MSI: D:\techsupport\RAWS32\install\media\Symantec Backup Exec Remote Agent for Windows Systems.msi
05-18-2010,08:58:53 : Discovered Total Actions: 122
05-18-2010,08:58:53 : The return code from the MSI is: 2
05-18-2010,08:58:53 : AgentSeqDlgs::PostInstallActions
05-18-2010,08:58:53 : Cleaning up the symc status key
05-18-2010,08:58:53 : The return value for Symantec Backup Exec Remote Agent for Windows Systems returned error code: 2
05-18-2010,08:58:53 : Clean up Symantec installer keys.
05-18-2010,08:58:57 : AgentSeqDlgs::Misc_BE_CommonOps
05-18-2010,08:58:57 : The Installation Failed!
 

Cause

  • This error can occur if 'User Account' which user is logged into the System, have proper permissions to run the Veritas Backup Exec Remote Agent for Windows Systems.msi or does not have proper previlages on the Install directory.
  • If the user running the installation of RAWS from a External USB drive.
  • If the user running the install via RDP (remote desktop) where Terminal Services are Enabled.
     

Solution

  • Login to the particular server using User Account which has local admin privileges and run the setup.
  • If the user running the setup of RAWS from a USB drive, then user must copy the installation files to local drive on the remote server and run the RAWS setup.
  • Instead of connecting to the remote server via RDP, logon to the particular remote server directly and run the setup. Users can also connect via RDP using console switch i.e. Click on Start, Run, type mstsc /console and click OK.
  • The RAWS installation files might have corrupted or missing some of its contents. User can copy a new RAWS32 / RAWSx64 folder from the media server to any of the local drives of the remote server and try running the installation again. (the default location of RAWS files on Media server is C:\Program Files\Veritas\Backup Exec\Agents). RAWS installation files are also on Backup Exec installation DVD, users can copy the RAWS installation folder from there also.
  • Veritas recommend to perform a push installation of the Remote Agent from the Backup Exec server. 
 

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