NetBackup for Microsoft SharePoint backup fails with Status Codes 114 and "-536836945: invalid error number" in the Activity Monitor.

Article: 100001726
Last Published: 2012-05-16
Ratings: 2 0
Product(s): NetBackup

Problem

NetBackup for Microsoft SharePoint backup fails with Status Codes 114 and "-536836945: invalid error number" in the Activity Monitor.

An MS-SharePoint policy was configured properly and when started it would fail immediately with the above error codes. Backups items were enumerated properly in the Backup, Archive and Restore (BAR) program on the SharePoint front end web server.  Permissions for the SharePoint admin account were verified to be correct. Backups of the index files on the index server were successful.

Error Message

Activity Monitor:

unimplemented error code (114)
...and...
invalid error number (-536836945)

The bpbkar log on the back end SQL Server:

<2> ov_log::V_GlobalLog: INFO - bedsSharePointV2InitRemote(): Calling FS_BlowOutMachine() to create additional DLEs. device XXX-XXXX returned 0
<2> ov_log::V_GlobalLog: ERR - bedsSharePointV2InitRemote():DLE_FindByName() for '\\XXX-XXXX\Microsoft SharePoint Resources' Failed! (0xE00084AF:The directory or file was not found, or could not be accessed. )
<2> ov_log::V_GlobalLog: ERR - unable to initialize the required BEDS SPS interface
...
<2> tar_base::V_vTarMsgW: INF - EXIT STATUS -536836945: invalid error number

Cause

Potentially using incorrect SharePoint domain administrator account.

Solution

Ensure that the NetBackup Client Service and the NetBackup Legacy Network Service on each server in the SharePoint Farm are logged on as a Windows domain account that is a member of the SharePoint Farm Administrators group.

Ensure that the SharePoint settings in the NetBackup Host Properties for each client in the SharePoint Farm Servers list (front web apps, index, SQL) include the domain\account and password of the SharePoint admin account. In the case of a clustered SQL Server, credentials should be entered on all the nodes of the cluster. This is done via the NetBackup Administration console:

  1. Host Properties > Clients, then select the appropriate client and double-click, to open its properties.
  2. Expand Windows Client, then click SharePoint.
  3. In the Client Properties dialog, add the correct SharePoint domain administrator account.

Was this content helpful?