Error bpbrm ERROR: V-3-20002: Cannot access /dev/vx/dsk/sfsdg/xxxx: No such file or directory when backup the MSDP catalog of Access appliance
Problem
The MSDP catalog backup is completed successfully, but there is an error message in the details of the job.
Error Message
The Job Details in the Activity Monitor shows that the backup is successful, but bpbrm show error messages such as "No such file or directory" referring to the MSDP filesystem(s) on Access:
Nov 17, 2022 8:19:07 PM - Info bptm (pid=4082) start backup
Nov 17, 2022 8:19:08 PM - Info bptm (pid=4082) backup child process is pid 4186
Nov 17, 2022 8:19:08 PM - Error bpbrm (pid=3992) from client myclient: ERROR: V-3-20002: Cannot access /dev/vx/dsk/sfsdg/client: No such file or directory
Nov 17, 2022 8:19:08 PM - Error bpbrm (pid=3992) from client myclient: ERROR: V-3-20002: Cannot access /dev/vx/dsk/sfsdg/msdp: No such file or directory
Nov 17, 2022 8:19:08 PM - begin writing
Nov 17, 2022 8:19:09 PM - Error bpbrm (pid=3992) from client myclient: ERROR: V-3-20002: Cannot access /dev/vx/dsk/sfsdg/catalog: No such file or directory
Nov 17, 2022 8:19:09 PM - Error bpbrm (pid=3992) from client myclient: ERROR: V-3-20002: Cannot access /dev/vx/dsk/sfsdg/msdp: No such file or directory
Nov 17, 2022 8:19:09 PM - Info bptm (pid=4082) waited for full buffer 14 times, delayed 53 times
Nov 17, 2022 8:19:09 PM - Info bptm (pid=4082) EXITING with status 0 <----------
Nov 17, 2022 8:19:09 PM - Info nbu (pid=4082) StorageServer=PureDisk:nbu; Report=PDDO Stats for (nbu): scanned: 75023 KB, CR sent: 129 KB, CR sent over FC: 0 KB, dedup: 99.8%, cache disabled, where dedup space saving:98.9%, compression space saving:0.9%
Nov 17, 2022 8:19:09 PM - Info bpbrm (pid=3992) validating image for client myclient
Nov 17, 2022 8:19:09 PM - Info bpbkar (pid=18949) done. status: 0: the requested operation was successfully completed
Nov 17, 2022 8:19:09 PM - end writing; write time: 0:00:01
The requested operation was successfully completed. (0)
The bpbkar debug log show the error message:
08:19:07.085 [18949] <2> bpbkar SelectFile: INF - Resolved_path = /vx
08:19:07.085 [18949] <4> bpbkar SelectFile: INF - VxFS filesystem is /vx for /vx
08:19:07.091 [18949] <4> bpbkar SelectFile: WORM status for </vx> is <0> rc = <19>
08:19:07.091 [18949] <4> bpbkar SelectFile: INF - Couldn't get VxFS file system layout: Cannot access /dev/vx/dsk/sfsdg/catalog: No such file or directory
08:19:07.091 [18949] <2> bpbkar resolve_path: INF - Actual mount point of /vx is /vx
Cause
Since the NetBackup client of Access Appliance is a docker container, the Access Appliance host mounts the VxFS to the NetBackup client.
There are no device files: /dev/vx/dsk/sfsdg/ on the NetBackup client, but this is the expected behavior.
Solution
The call is to get the FS layout when performing backup. This is not a functional issue and the error can be ignored as the backup is successful