NetBackup Web Management Console Service does not start because of corrupt tomcat-coyote.jar file

Article: 100053807
Last Published: 2022-08-19
Ratings: 3 0
Product(s): NetBackup & Alta Data Protection

Problem

NetBackup Web Management Console Service does not start because of corrupt tomcat-coyote.jar file

Error Message

Error in /usr/openv/wmc/webserver/logs/catalina.yyyy-mm-dd.log file:

19-Aug-2022 02:38:13.178 SEVERE [main] org.apache.tomcat.util.digester.Digester.startElement Begin event threw error
  java.lang.ClassFormatError: Unknown constant tag 110 in class file org/apache/coyote/Adapter

Cause

The following file was found to be corrupt on the Primary Server:

/usr/openv/wmc/webserver/lib/tomcat-coyote.jar

You can run the below command for the file and compare the numerical hash value shown with that of the same file from a working master server:

# /usr/openv/netbackup/bin/goodies/support/versioninfo -f /usr/openv/wmc/webserver/lib/tomcat-coyote.jar
======= /usr/openv/wmc/webserver/lib/tomcat-coyote.jar =======
 -  2200760796

Solution

Replace the file /usr/openv/wmc/webserver/lib/tomcat-coyote.jar from the one obtained from a working Primary Server with the same NetBackup version and same operating system version.

Note: Although in this case tomcat-coyote.jar file was found to be corrupt, you can face instances where you observe the error 'Unknown constant tag'.
In that case, you can try to find out which file in path /usr/openv/wmc/webserver/lib is corrupt by running versioninfo command on each file and then compare it with a working Primary Server's files.

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