Active Directory Users & Groups not visible in Appliance UI's if non UTF-8 characters used

Article: 100048300
Last Published: 2020-09-23
Ratings: 0 0
Product(s): Appliances

Problem

If a NetBackup Appliance is integrated with Active Directory for user Authentication if any non UTF-8 characters are used for the user records which are synced to the Appliance then all the user & group records will not be displayed. If permissions had been previously granted these will continue to work.

Error Message

In the appliance Web Interface the users will not be displayed in the Command Line Shell an error similar to below will be displayed:

 nbapp01.Authorization> list
/usr/openv/runtime_data/ldapauthIdM1Z.tmp:1: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0xE9 0x6E 0x65 0x7A
User><User Access="Allowed" Role="Administrator" UserType="Ldap"><Name>Jim

Cause

There is an issue with the software which handles the display of the user details when  non UTF-8 characters are used which results in all users not being displayed.

Solution

This issue is currently being considered by Veritas Technologies LLC to be addressed in the next major revision of the product.  There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time.  Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability.  Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

If you already have encountered this issue then please contact Veritas Technical Support referencing this document and they will be able to assist.
 

References

JIRA : APPCFT-6592

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