Attempting a manual backup with a UBAK schedule type, jobs quickly end with a Status 12; BPCD_WHITELIST_PATH listing progress log location is in place

Attempting a manual backup with a UBAK schedule type, jobs quickly end with a Status 12; BPCD_WHITELIST_PATH listing progress log location is in place

Article: 100048125
Last Published: 2020-07-31
Ratings: 1 0
Product(s): Appliances, NetBackup

Problem

When performing manual backups initiated from a Client host, jobs might end with a Status 12 if the progress log specifies a location under the '/usr/openv/' location. This can happen even if the path is listed in BPCD_WHITELIST_PATH entry.

Error Message

Job Details:

07/30/2020 07:45:42 - Error bprd(pid=191564) Unable to write progress log </usr/openv/scripts/my_logs_folder/bkup_file_log.20200730> on client clientName.acme.com. Policy=MyBackupPolicy Sched=UserBackupSchedName

07/30/2020 07:45:42 - Error bprd(pid=191564) CLIENT clientName.acme.com  POLICY MyBackupPolicy  SCHED UserBackupSchedName  EXIT STATUS 12 (file open failed)

 

BPRD log snippet:

07:45:41.801 [191564.191564] <2> logconnections: BPCD CONNECT FROM 127.0.0.1.33390 TO 127.0.0.1.37940 fd = 5

07:45:41.801 [191564.191564] <2> vnet_connect_to_vnetd_bpcd: js_bpcd_info: 0xf85780

07:45:41.801 [191564.191564] <2> vnet_pbxConnect_ex: pbxConnectExEx Succeeded

07:45:41.849 [191564.191564] <2> vnet_set_domain_ctx: request VN_REQUEST_SET_DOMAIN_CTX 21

07:45:41.851 [191564.191564] <8> do_pbx_service: [vnet_connect.c:3510] via PBX VNETD CONNECT FROM 10.0.0.11.54746 TO 10.0.0.20.1556 fd = 8

07:45:41.851 [191564.191564] <8> vnet_vnetd_connect_forward_socket_begin: [vnet_vnetd.c:476] VN_REQUEST_CONNECT_FORWARD_SOCKET 10 0xa

07:45:41.852 [191564.191564] <8> vnet_vnetd_connect_forward_socket_begin: [vnet_vnetd.c:501] ipc_string /usr/openv/var/tmp/vnet-35355596120341852475000000026-i1S9IC

07:45:41.894 [191564.191564] <2> bpcr_get_version_rqst: bpcd version: 08200000

07:45:41.934 [191564.191564] <8> append_to_client_log: couldn't open log file /usr/openv/scripts/my_logs_folder/bkup_file_log.20200730 on client octopus, error = 6000

07:45:41.934 [191564.191564] <16> append_to_client_log: Access to /usr/openv/scripts/ships_backups_logs/bkup_file_log.20200730 denied: The provided path is not whitelisted

07:45:41.936 [191564.191564] <8> bkarfiles: failure writing progress log on client clientName.acme.com in log /usr/openv/scripts/my_logs_folder/bkup_file_log.20200730:  file open failed (12)

Cause

It is not recommended to put custom data in the '/usr/openv/' path structure. Placing data under '/usr/openv/' that is not created by NetBackup normally risks overwriting/removing/deleting files needed for operations. If a custom progress log location is placed under '/usr/openv' a file open failed message is likely.

Solution

The general recommended action is to use a location outside the '/usr/openv/' structure for progress log files, and then adding that path in BPCD_WHITELIST_PATH on the Client host that initiates the backup. If my custom progress log directory is /home/root/myLogs, the BPCD_WHITELIST_PATH entry can be added as follows:

 

# echo BPCD_WHITELIST_PATH=/home/root/myLogs |nbsetconfig

NOTE: An exception to this general rule is the use of a custom directory under '/usr/openv/netbackup/logs'.

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