EEBs to resolve an issue where AutoSupport collector stops gathering inventory data for Appliance 2.7.2, 2.7.3 and 3.0 releases

EEBs to resolve an issue where AutoSupport collector stops gathering inventory data for Appliance 2.7.2, 2.7.3 and 3.0 releases

Article: 100034263
Last Published: 2017-08-08
Ratings: 0 0
Product(s): Appliances

Problem

The AutoSupport CallHome collector runs every 15 minutes to collect product information, serial number, firmware version and other inventory data. The data packages are sent to Veritas every 24 hours. When an invalid plugin is detected, the data collection stops working due to the internal logic error where hung-up signals are not ignored and eventually, the data packages received by Veritas become inconsistent.

Error Message

No error message.

Cause

The collector stops gathering data due to an internal logic error that occurs when hung-up signals are not ignored.

Solution

The attached hot-fix corrects the internal logic error; once installed, the invalid plugins will be reported but the hung-up signals will be ignored.  As a result, the AutoSupport collector will continue to gather data on other plugins, and the data packages received by Veritas' CallHome servers remains consistent.

Apply the hot-fix (found by accessing the Download Attachments link) that corresponds to your Appliance NetBackup version.  For instructions on installing EEBs and Hot-fixes, refer to article number 000076512 by clicking the Related Articles link on this page.


Note:
The NetBackup Appliance 2.7.3 and 3.0 versions of the hot-fix also contains fixes for two additional issues:
  • An 'incomplete CallHome telemetry data report with proxy' issue (see 000127224 for more information)
  • Suppression of non-actionable alerts (see 000127174 for more information).
The NetBackup Appliance 2.7.2 version also contains the fix for the following issue:
  • An incomplete CallHome telemetry data report proxy issue (see 000127224 for more information)
If you have installed the hot-fixes for those issues, you do not need to install the hot-fix for the 'AutoSupport collector stops gathering data ' issue discussed here.


 

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