The message "Search is returning partial results..." is displayed when searching a Windows 2012 EV server with a NIC Team

The message "Search is returning partial results..." is displayed when searching a Windows 2012 EV server with a NIC Team

Article: 100031719
Last Published: 2016-01-04
Ratings: 0 0
Product(s): Enterprise Vault

Problem

EV Search may display the message "Search is returning partial results because Enterprise Vault could not search the whole vault" when searching index locations that are hosted in an Index Server Group.  For this specific issue to occur, at least one of the EV servers within the Index Server Group will have a Windows 2012 NIC Team with a standby adapter configured, together with an additional NIC that is part of a separate network (such as a network that is used for the backup of the server).

Error Message

A dtrace of AuthServer and EVIndexQueryServer will show AuthServer lines indicating that the hostname for the backup network rather than the production network is being used to generate the auth token when running the search:

(AuthServer) <4828> EV:L {CClientAuthIntImpl::RegisterClientIdentity:#829} Completed registration. Token
[backup_net_hostname.testdomain.local T1pW*****], SID count [13], Cancel Id [21144400].

(EVIndexQueryServer) <2652> EV-M {SOAPSearchHelpers}
EV_AUTH_TOKEN from SOAP headers = backup_net_hostname.testdomain.local g1aA*****

(EVIndexQueryServer) <8040> EV:L {VaultCoCreateInstanceEx} Attempt [1] to create COM object failed. CLSID
[{4D5CA60E-4358-11D4-8687-0008C7DF84BC}] Server Name [backup_net_hostname.testdomain.local]
Elapsed [41.651s] Result [The RPC server is unavailable.  (0x800706ba)]

(EVIndexQueryServer) <2652> EV-H {SearchService} Exception: Failed to confirm client identity from auth token.
Info:SearchService.Search failed. Diag:
Type:Symantec.EnterpriseVault.Indexing.Search.SearchPermissionException ST:   at
Symantec.EnterpriseVault.Indexing.Search.UserPermissions.SetCallerIdentity(String authToken)|
  at Symantec.EnterpriseVault.Indexing.Search.SearchService.Search(Search
search) Inner:System.Runtime.InteropServices.COMException (0x800706BA): The RPC
server is unavailable. (Exception from HRESULT: 0x800706BA)|   at
KVS.EnterpriseVault.Interop.ClientAuthenticateClass.ConfirmClientIdentity(String
authstring, String& domain, String& username, Object& sids, String& serverdom,
String& serveruser)|   at
Symantec.EnterpriseVault.Common.AuthClient.AuthClient.ConfirmClientIdentity(String
authString)|   at
Symantec.EnterpriseVault.Indexing.Search.UserPermissions.SetCallerIdentity(String authToken)

Cause

When a Windows 2012 NIC Team is used with a standby adapter configured Enterprise Vault is unable to accurately determine the hostname or IP Address of the production network when it generates its auth token.  Adjusting the binding order of the NIC's does not correct the problem.

Solution

Workarounds:

Create Hosts file entries on all EV servers in the Index Server Group that resolve the backup network hostname for each EV server to their corresponding  production network IP address.

or

Delete the PTR record for the backup network hostname from DNS

or

Set all NIC's in the Windows 2012 team to be active


Veritas has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article.

This issue is currently under investigation by Veritas. Pending the outcome of the investigation, this issue may be resolved by way of a cumulative hotfix or service pack in the current or future versions of the software. However, this particular issue is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns. For information on how to contact Veritas Sales, please see http://www.Veritas.com.

Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

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