A backup job targeted to tape on a server with the HP Server Management Agents software installed may report 0xe00084f4 - An unknown error has occurred

Article: 100018653
Last Published: 2023-09-19
Ratings: 0 0
Product(s): Backup Exec

Problem

"An unknown error occurred" may occur when backing up to tape on a server with the HP Server Management Agents Software and/or HP StorageWorks Managements software installed.

 

Error Message

0xe00084f4 - An unknown error has occurred
Completed status: Failed
Final error: 0xe00084f4 - An unknown error has occurred.
Final error category: System Errors

For additional information regarding this error refer to link V-79-57344-34036

UMI code :V-79-57344-34029
 

Cause

 
The SCSISTAT_QUEUE_FULL error is often caused by a conflict with the HP Insight Server Management Agent software or the HP StorageWorks VDS Hardware Providers for MSA Disk Arrays software.  This condition can be confirmed by running TRACER.EXE and performing a SCSI trace on the failing hardware.  See related documents for more information on how to use TRACER.EXE.
 
The following SCSISTAT_QUEUE_FULL error will be seen on a WRITE6 command (Figure 1):
 
Figure 1
   
 

The STATUS_DEVICE_NOT_CONNECTED error may also be caused as the Driver Result (Figure 2):

Figure 2
STATUS_DEVICE_NOT_CONNECTED

When getting the STATUS_DEVICE_NOT_CONNECTED error, the Device error 1167 is reported in the adamm.log.

Note: The SCSI trace in the adamm.log does not report the Driver Result.

[7832] 11/12/12 00:18:44.225 DeviceIo: 04:07:00:00 - Device error 1167 on "\\.\Tape0", SCSI cmd 4d, 1 total errors
[3312] 11/12/12 00:19:50.400 PvlDrive::DisableAccess() - ReserveDevice failed, offline device
       Drive = 1023 "TapeDRV1"
       ERROR = 0x0000001F (ERROR_GEN_FAILURE)

[3312] 11/12/12 00:19:50.400 PvlDrive::UpdateOnlineState()
       Drive = 1023 "TapeDRV1"
       ERROR = The device is offline!
...

...

SCSI: ==========================================================================
SCSI: CDB 04:07:00:00 Start 00:18:44.225 End 00:18:44.225 Duration 0.000000
SCSI: Function                                SRB_FUNCTION_EXECUTE_SCSI
SCSI:
SCSI: Raw CDB
SCSI: 4D 00 71 00 00 00 00 00 24 00                   M.q.....$.
SCSI:
SCSI: CDB Operation                           LOG_SENSE
SCSI:  LUN                                    0
SCSI:  PPC                                    False
SCSI:  SP                                     False
SCSI:  Parameter pointer                      0
SCSI:  Alloc length                           36
SCSI:  Control                                0x00
SCSI: Data
SCSI: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
SCSI: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
SCSI:
SCSI:
SCSI: Capture dropped 2838409 events
SCSI: Capture dropped 6059 events
SCSI: Capture dropped 3314492 events
[3312] 11/12/12 00:19:50.697 End dump of device SCSI history

Also Refer this HP Link :
https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c02655717
 

Solution

 
1.  Install the latest version of HP Insight Agents and test another backup.
 
2.  Run the StorageWorks Library and Tape Tools (L&TT) and run a 100GB backup test.
 
A. Download and install the latest version of L&TT -   https://www.hp.com/support/tapetools
 
B. Stop the Backup Exec services.
 
C. Insert a scratch tape into the drive.   * ***Important! This needs to be a scratch tape as the HP L&TT test will overwrite the data on the tape.
 
D. Select the drive that you want to test under the "By Product" tab.
 
E. Click on the TEST icon at the top of the window.
 
F. Drill down to READ/WRITE test in the TEST GROUP FIELD.
 
G. Click on the Options button.
 
H. The Options window will open. You can double click on the "Amount of data written/read in each phase" and change the amount of data to the 100 GB.
 
The L&TT test will now write 100GB of test data to the drive. If this test fails, then contact HP Technical Support for further troubleshooting. 
 

3. Increase BusyRetryCount and test another backup.

Please refer to 100025038 to increase BusyRetryCount.

4. Disable the HP Management Agents and Services

Disable WMI Storage Service (will require a server reboot)
 
Go to Control Panel > HP Management Agents, select the Services tab, then move SCSI and SAS Information to the Inactive Agents column. 

From under the Storage tab disable the following :
Disable Fibre Agent Tape Support
Disable Smart Array Agent Tape Support
Disable SAS Agent Tape Support
Disable Smart Array Performance Monitoring  

Retry the backup job. If it still fails, try moving the performance monitor agent to the Inactive Agents column and try the backup again. 

5. Disable the following HP services, and reboot the server and test another backup.  

   -  HP Insight Server Agents
   -  HP Insight Storage Agents
   -  HP Insight Foundation Agents
   -  HP WMI Storage Providers service
 
NOTE: Not all Four services may be present. Only disable what is listed above as these services conflict with the Veritas drivers which are updated for tape drives.
 
6.  Uninstall the HP StorageWorks VDS Hardware Providers for MSA Disk Arrays software and test another backup. 

This software is installed on HP Storage Servers by default. This software may not be listed in Control Panel > Uninstall a program. Please contact HP Technical Support to uninstall this program.

7.  Uninstall the HP Insight Manager software and test another backup. 

8. If there is any third party backup software which is not in use may block the tape device and may cause conflict. Uninstall and test another backup.

NOTE : If disabling the HP services or removing HP softwares resolves the error, please contact HP Technical Support for further assistance. 

 

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