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1

Basic tasks
This chapter includes the following topics:
■

Displaying HyperScale storage data

■

Working with data nodes

■

Working with compute nodes

■

Displaying alerts so you can take corrective action

Displaying HyperScale storage data
The HyperScale dashboard gives you an overview of important storage statistics.
Use the dashboard to monitor the overall health of your environment or identify
HyperScale events and alerts that need your attention. You can also use the
dashboard to focus on specific nodes, workloads (instances), or tenants.

Overall storage view
The Overall view is an aggregate display of storage under HyperScale management
in your cloud environment. The overall view does not focus on a specific node or
workflow.
This view is divided into four areas:
■

Compute plane statistics

■

Data plane statistics

■

Tabs that display graphs for I/O per second (IOPS), throughput, and latency

■

An alerts area
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Figure 1-1

Compute plane statistics

The Compute Plane area displays the following:
■

Persistent storage and cache usage; you can hover over the doughnut icons to
get more details data about used and free storage

■

Overall IOPS, throughput, and latency

Figure 1-2

Data plane statistics

The Data Plane area displays the following:
■

Persistent storage and cache usage; you can hover over the doughnut icons to
get more details data about used and free storage

■

The number of instance snapshots stored on the data plane, both the total
number (admin and user snapshots) and those taken by users alone

■

The number of virtual disks (vDisk) on the data plane

■

The number of backups that have occurred

■

The number of exports to the external storage provider
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Figure 1-3

The Alerts area

The Alerts area of theHyperScale dashboard displays information or errors that
you may need to take action on. Situations in which alerts are displayed include
the following:
■

Compute node or data node goes down.

■

SSD usage on the compute node exceeds 90%.

■

I/O errors occur on the compute node, including I/O errors on the vDisks.

■

HDD usage on the data node exceeds 90%.

See “HyperScale alerts reference” on page 72.

Primary storage view
The Primary storage view lets you focus on individual nodes in the compute plane.
Use the drop-down menu to select Primary. Start typing the name of a node in the
search box and click Show Summary. This view displays storage and performance
statistics for the specified compute node.
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Figure 1-4

Statistics for a specific compute node

In this view, the Alerts area, and the performance tabs at the bottom of the screen
only show information for the specified node.
See “HyperScale alerts reference” on page 72.

Secondary storage view
The Secondary storage view lets you focus on individual data nodes in the data
plane. Use the drop-down menu to select Secondary. Start typing the name of a
node in the search box and click Show Summary. This view displays the same
types of data plane statistics as the overall view, but only for the specified data
node.
Figure 1-5

Statistics for a specific data node

The Alerts area only shows information for the specified node.

Workload view
The Workload storage view lets you focus on instances running in your HyperScale
environment. Use the drop-down menu to select Workload. Start typing the name
of instance in the search box and click Show Summary. This view displays the
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same types of compute and data plane statistics as the overall view, but only for
the specified instance.
Figure 1-6

Statistics for a specified instance

In this view, the Alerts area, and the performance tabs at the bottom of the screen
only show information for the specified instance.

Tenants view
The Tenants storage view lets you focus on individual tenants running in your
HyperScale environment. Use the drop-down menu to select Workload. Start typing
the name of tenant in the search box and click Show Summary. This view displays
the same types of compute and data plane statistics as the overall view, but only
for the specified tenant.
Figure 1-7

Compute plane statistics for a specific tenant
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Figure 1-8

Data plane statistics for a specific tenant

In this view, the Alerts area, and the performance tabs at the bottom of the screen
only show information for the specified tenant.

Working with data nodes
This section describes basic data node tasks.

Adding a data node
Adding a data node is the first task you perform after installing HyperScale on the
OpenStack controller. You can add a data node from the HyperScale graphical
user interface (GUI) or from the command line.

Before you proceed
Check for the following:
■

Ensure that you have installed HyperScale on the OpenStack controller

■

Keep the following information ready. You will need to specify these details while
adding a data node.

■

■

The management IP address of the Cinder node on which you are adding
the data node.
In the minimum production environment, this Cinder node is the controller
system.

■

The Cinder node password.

■

The OpenStack admin password.

Make sure that the disks you intend to use for data node storage have the msdos
label type.

About adding data nodes
HyperScale supports up to two data nodes. In the minimum production environment,
the first data node you add must be on the same node as the HyperScale controller.
In the preferred production environment, both data nodes are hosted on different
physical nodes.
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Data nodes are used to store point in time snapshots of virtual machine volumes.
Every 15 minutes, the compute nodes write new data to the data plane. This
operation is known as Episodic Data Synchronization.
In addition, if there are two data nodes in the environment, for the VRTSSilver flavor
and above, one data node is the primary data node and the other is the secondary
data node. In this configuration, data is reflected from the primary data node to the
secondary data node. If one of the data nodes fail, all requests are served from the
other data node.
For virtual machines with the VRTSBronze flavor, there is no reflection at the data
node level. If the data node that is associated with a Bronze virtual machine fails,
you cannot access all the volume versions.

Adding a data node from the HyperScale GUI
To add a data node from the graphic user interface

1

Launch a web browser and type the URL that you noted during the HyperScale
installation.
The URL format is as follows:
http://<FQDN>/horizon/storage

Here, <FQDN> is the fully qualified domain name of the controller node.
Note: You can also use the public IP address of the controller node in the URL:
http://<publicIPaddressofcontroller>/horizon/storage

2

Specify the OpenStack admin user name and password on the login page and
click Connect.

3

Navigate to HyperScale > System > Data Nodes.
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4

On the Data Nodes page, click Add Data Node.

5

Perform the following actions on the Add Data Node panel:
■

Specify the requested details as described in the following table:
Field name

Description

Management IP address Specify the IP address assigned to the management
network interface on the node that you want to add as
a data node.
Typically, the first data node is the same as the
controller node.

Note: Do not specify the public IP address of the
node.

■

Hypervisor Password

Specify the administrator password of the node that
you want to add as a data node.

OpenStack Password

Specify the OpenStack administrator password.

Click Discover.

HyperScale discovers the network interfaces and storage on the node.
■

From the Data plane interface drop-down list, select the network interface
associated with the HyperScale data network.
The drop-down list displays a network interface only if it is enabled and an
IP address is assigned to it.
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Note: Do not select any other interface.

■

Assign storage for the meta disk and data disks.
Select disks from the Available disks area and use the right arrow icons
to move them to the Meta disk area and Data disks area.
At a minimum you need two disks—one for the meta disk and one for the
data disk. For better performance, choose a solid-state drive (SSD) for the
meta disks. If you specify multiple SSDs for the meta disks, HyperScale
automatically creates mirrored volumes on them. Mirrored metadata ensures
that even if one SSD fails, the data node continues to work and does not
have to switch to an alternate data node.

■

Click Add Data Node.
HyperScale begins to configure the data node. The dashboard displays
various messages that indicate the progress.
After the process is complete, the name of the data node that you just added
appears in the GUI under HyperScale > System > Data Nodes.
If there are any failures during the add node operation, refer to the log file
to troubleshoot the issues. To access the log file for a specific data node,
on the Data Nodes tab, under the Logs column, click the Download link
for that node.

Adding a data node using HyperScale commands
Perform the following steps on the controller node to add a data node using
HyperScale commands.
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To add a data node from the command line

1

On the controller node, source the OpenStack RC file. This operation sets the
required environment variables.
# source keystonerc_admin

2

Add the data node using the dn-add command. It has the following syntax:
# hyperscale dn-add [--data_disks <data_disks>]
[--meta_disk <meta_disk>] datanode-mgmt-ip
<datanode-pwd> <openstack-pwd>
<dndata-itface> <data_cidr_range>

Here, <data-mgmt-ip> is the IP address associated with the management
network interface and <dndata-itface> is the name of the interface associated
with the data network.
Use commas to specify multiple disks.
Example:
# hyperscale dn-add --data_disks /dev/mapper/mpathb,/dev/mapper/mpathc
--meta_disk /dev/fioa
172.202.202.1 root123 admin123
eth5 172.202.202.0/24

3

Monitor the add operation as it progresses.
Check the following log file on the controller node:
/var/opt/VRTSofcore/log/<datanode_mgmtip>_config.log

4

Verify that the data node was created. The nodes table has an entry for the
new data node and the data node's status appears as up.
The following abbreviated output shows the hostid of the new data node and
its status:
# hyperscale nodes
+----------------------------------------+
| hostid
|
+----------------------------------------+
{0001a036-9f33-3ea0-0000-000000000000}
|

...
...
...
...

+--------+
| status |
+--------+
| up
|

...
...
...
...

If an error occurs when you add a data node, information is written to the
/var/opt/VRTSofcore/log/<datanode_mgmtip>_config.log file on the controller
node.
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Removing a data node
Before you remove a data node, make sure of the following:
■

HyperScale must be disabled on the compute nodes.
See “Disabling HyperScale on a compute node” on page 23.

■

You have the hypervisor password and OpenStack password of the data node
you want to remove.

To remove a data node

1

Navigate to HyperScale > System > Data Nodes.

2

On the All Data Nodes table, locate the data node, and in the Actions column
click Remove Data Node.

3

On the Remove Data node dialog box, enter the hypervisor password and the
OpenStack password.

4

Click Remove Data node.

5

On the All Data Nodes page, the Status column is updated as the data node
is removed.

If any issues occur during this task, you can download the data node log from the
All Data Nodes page, or view the log on the following path:
/var/opt/VRTSofcore/log/<datanode_mgmtip>_config.log

Removing a data node that has computes enabled is possible only in the following
cases:
■

A network failure on the data node has triggered a datanode failover and that
has caused the vdisks to be evacuated to a peer data node

■

A permanent data node service failure where the service does not start even
after three restart attempts

■

If there is a storage failure
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See “Data node resiliency” on page 55.

Working with compute nodes
This section describes basic compute node tasks.

Enabling HyperScale on a compute node
You can enable HyperScale on a compute node from the graphical user interface
(GUI) or from the command line.

Before you proceed
The following information is required to enable HyperScale on a compute node:
■

The hypervisor password

■

The OpenStack password

About enabling HyperScale on compute nodes
The HyperScale compute node hosts the workloads. Although you can run all
services on a single compute node, you can add additional compute nodes to scale
out and expand your HyperScale cloud environment.
To make sure that the data on your compute nodes is resilient, you must enable
HyperScale on enough compute nodes to account for the reflection factor (the
number of nodes to which the data is written) plus one. You need the additional
compute node in case one of the reflection targets goes down. The reflection factor
is based on the HyperScale flavor you assign to the virtual machines.
The following table shows the minimum number of compute nodes you need for
each virtual machine flavor.
Minimum number of compute nodes to provide resiliency

Table 1-1
Flavor

Reflection factor Compute nodes
(including the source compute node)

VRTSSilver 1

3

VRTSGold

4

2

If an error occurs when you enable HyperScale on a compute node, information is
written to the following log file on the controller node:
/var/opt/VRTSofcore/logs/<computenode_mgmtip>_config.log
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Enabling HyperScale on a compute node using the GUI
To enable HyperScale from the GUI

1

Launch a web browser and type the HyperScale dashboard URL.
The URL format is as follows:
http://<FQDN>/horizon/storage

Here, <FQDN> is the fully qualified domain name of the controller node.
You can also use the public IP address of the controller node in the URL:
http://<publicIPaddressofcontroller>/horizon/storage

2

Specify the OpenStack admin user name and password on the login page and
click Connect.

3

Navigate to HyperScale > System > Hypervisors.

4

In the All Hypervisors table, locate the hypervisor host on which you want to
enable HyperScale and on the right side of the table, under the Actions column,
click Enable HyperScale.

5

Perform the following actions on the Enable HyperScale panel:
■

■

Specify the requested details as described in the following table:
Field name

Description

Hypervisor Password

Specify the administrator password of the node on which
you want to enable HyperScale.

OpenStack Password

Specify the OpenStack administrator password.

Click Discover.
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HyperScale discovers the storage for the specified hypervisor.
■

Assign disks for the Cache and Persistent storage.
Select disks from the Available disks area and use the right arrow icons
to move them to the Cache area and Persistent storage area.
At a minimum you need two disks—one for the cache and one for persistent
storage. For better performance, choose a solid-state drive (SSD) for the
cache.

■

Click Enable HyperScale.
HyperScale begins to enable HyperScale on the hypervisor. The dashboard
displays various messages that indicate the progress.
After the process is complete, the status under the HyperScale column
displays as Enabled/Running.
If there are any failures during the operation, refer to the log file to
troubleshoot the issues. To access the log file for a specific hypervisor, on
the Hypervisors tab, under the Logs column, click the Download link for
that hypervisor.

Enabling HyperScale from the command line
Perform the following steps on the controller node to enable HyperScale on a
compute node using commands.
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To enable HyperScale from the command line

1

On the controller node, source the OpenStack RC file to set the required
environment variables.
# source keystonerc_admin

2

Enable HyperScale on the hypervisor using the compute-enable command.
# hyperscale compute-enable [--data_intf <data-intf>]
<compute-ip> <compute-pwd> <openstack-pwd>
<compute-meta-disks>
<compute-data-disks>

Here, <data-intf> is the name of the interface associated with the data network
and <compute-ip> is the IP address associated with the management network
interface.
Use commas to specify multiple disks.
Example:
# hyperscale compute-enable --data_intf ens224
172.101.101.7 root123 admin@123
/dev/dbcomputestore/ssddisk3,/dev/dbcomputestore/ssddisk4
/dev/dbcomputestore/hdddisk3,/dev/dbcomputestore/hdddisk4

3

Monitor the operation as it progresses.
Check the following log file on the controller:
/var/opt/VRTSofcore/log/<computenode_mgmtIPaddress>_config.log

4

Verify that HyperScale was enabled on the compute node.
# hyperscale nodes

If there are any failures during the operation, refer to the following log file on the
controller node to troubleshoot the issues:
/var/opt/VRTSofcore/log/<computenode_mgmtIPaddress>_config.log

Disabling HyperScale on a compute node
To complete this steps in the section, you need the following information:
■

The hypervisor password

■

The OpenStack password
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To disable HyperScale in an OpenStack environment

1

Navigate to HyperScale > System > Hypervisors.

2

In the table, locate the hypervisor on which you want to disable HyperScale,
and on the right side of the table, click Disable HyperScale.

3

Complete the Disable HyperScale dialog box.

4

Click Disable HyperScale.

5

Verify that HyperScale is disabled.
On the All Hypervisors page, the HyperScale column updates as HyperScale
is unconfigured. When the operation is completes, the column displays
Disabled.

Displaying alerts so you can take corrective action
The Alerts area of the HyperScale dashboard displays information or errors that
you may need to take action on. Situations in which an alert is displayed include
the following:
■

Solid-state drive (SSD) usage on the compute node exceeds 90%.

■

I/O errors occur on the compute node, including I/O errors on the vDisk.
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■

Hard disk drive (HDD) usage on the data node exceeds 90%.

Alerts display information various parts of your HyperScale environment, including
compute nodes and data nodes, storage devices, instances, and vDisks.
See “HyperScale alerts reference” on page 72.
To display alerts
◆

Navigate to HyperScale > System > Overview.
An Alerts/Events table is displayed at the bottom of the page.
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Protecting HyperScale
instances with an external
storage provider
This chapter includes the following topics:
■

Integrating an external storage provider with HyperScale

■

External storage provider requirements

■

Installing the external storage provider

■

Registering an external storage provider

■

Creating and exporting a snapshot

■

Exporting a copy of a snapshot

■

Launching an instance from an exported snapshot

■

Launching an export from a deleted instance

■

Export and import activity logs

■

Changing the level of detail in log files

■

Purging exports to free up space on the external storage provider server

■

Troubleshooting external storage provider issues

■

Unregistering an external storage provider

■

Uninstalling the external storage provider

■

External storage provider commands

Protecting HyperScale instances with an external storage provider
Integrating an external storage provider with HyperScale

Integrating an external storage provider with
HyperScale
As a HyperScale infrastructure administrator, you may need to take regular
snapshots of critical instances (workloads). Taking regular snapshots helps prevent
the data loss that can occur from the following:
■

System failure

■

Data corruption due software issues

■

User errors

You also need to prepare for disaster recovery.
The HyperScale external storage provider is designed to meet these infrastructure
administrator needs. The external storage provider lets you create and export
HyperScale instance snapshots to an external storage device. The exported
snapshot can then be used to launch a new instance if the original becomes
corrupted, is accidentally deleted, or another data loss or disaster recovery situation
occurs.
You install this component on a separate system (node), also known as the external
storage provider node. It integrates with rest of the HyperScale components and
provides following features:
■

Create and export a snapshot
You can create new instance snapshots for instances running in your HyperScale
deployment and export these snapshots to the external storage provider node.
A temporary copy of the instance snapshot is created on primary/secondary
data node for the duration of export operation. Creating and exporting a snapshot
has almost no impact on I/O performance of the instance you export.
See “Creating and exporting a snapshot” on page 32.

■

Export a copy
You can copy a pre-existing instance snapshot and store it on the external
storage provider node. Exporting a copy has no performance impact on the
instance whose snapshot you export. After the export, pre-existing snapshot
remains unchanged on the secondary data node.
See “Exporting a copy of a snapshot” on page 33.

■

Launch an instance from an exported copy
You can launch a new instance from an export. You can launch the instance
from the same HyperScale deployment, or, in the case of a disaster recovery
situation, from a different HyperScaledeployment.
See “Launching an instance from an exported snapshot” on page 33.
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To use the external storage provider features, you must have the infrastructure
administrator role in HyperScale. Depending on the configuration of the guest agent
inside an instance, the exported snapshots are either crash consistent, file system
consistent, or application consistent.
Making sure that data is securely and efficiently transferred between the HyperScale
nodes (compute and data nodes) and external storage provider requires some
advance planning.
See “External storage provider requirements” on page 28.

External storage provider requirements
HyperScale's external storage provider lets infrastructure administrators create and
export HyperScale instance snapshots to an external storage device. The exported
snapshot can then be used to launch a new instance if the original becomes
corrupted, is accidentally deleted, or another data loss or disaster recovery situation
occurs. Making sure that data is securely and efficiently transferred between the
HyperScale nodes (compute and data nodes) and external storage provider requires
some advance planning.
You should connect the external storage provider to the same management and
data subnets as the rest of the HyperScale deployment.
If the external storage provider is located in the same rack as the other HyperScale
nodes, connect its two interfaces to the appropriate ports of the middle of the rack
switch. Each of the subnets should have its own virtual LAN (VLAN). The same
holds true even if the external storage provider is located in a different rack.
However, the middle of the rack switches must be properly connected and trunked
to enable intra-VLAN traffic between the two racks.
Before you integrate an external storage provider with HyperScale, the provider
must be installed on a separate node that is not part of the HyperScale environment.
The node must be a server-grade system with high I/O throughput. In addition, it
must meet the following requirements:
Table 2-1

Hardware requirements

Hardware

Requirement

RAM

32 GB minimum, 64 GB or higher recommended

Virtual CPUs

4 cores minimum, 8 cores recommended

Network speed

1 Gbps minimum, 10 Gbps recommended

Hardware type

Physical machine

28

Protecting HyperScale instances with an external storage provider
External storage provider requirements

Table 2-1
Hardware

Hardware requirements (continued)
Requirement

Network interface cards 3 required
(NICs)
■ A 1 Gbps management NIC. Configure this NIC to be on
the same management subnet as the compute node and
data node.
■ A 1 Gbps (minimum) data NIC. 10 Gbps is recommended.
Configure the other NIC to be on the same data subnet
as the compute node and data node.
■ A public network NIC to access the node and check logs
and perform troubleshooting.
Physical storage

Enough physical storage to maintain instance snapshots.
HyperScale maintains a full copy of an instance's vDisks and
metadata when it is exported to the external storage provider
node. For example, if you export five instances that have a
total of 5 TB of data written to their vDisks, the external
storage provider node requires 5 TB of storage.

Network

The firewall on the external storage provider node is disabled,
or port 8334 is open. (This must be verified before you try to
register the external storage provider from the HyperScale
user interface.)

Note: When the external storage provider imports or exports a snapshot, it
communicates with the primary and secondary data nodes using the management
and data subnets. (This is the same method that compute nodes and data nodes
use to communicate with each other.) Therefore, the external storage provider node
should either be in the same physical rack as the HyperScale nodes, or, if it is
outside the rack, it should be able to communicate to other HyperScale nodes using
the management and data subnets.
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Figure 2-1

Controller node and data node communication with the external
storage provider node

Table 2-2

Software requirements

Software

Requirement

Operating system

Red Hat Enterprise Linux (RHEL) 7.2 Infrastructure Edition
(minimum)

Web framework

Flask 0.10.1 or later

Python

2.7 or later

Installing the external storage provider
To install the external storage provider

1

On the external storage provider node, install Python.
> yum install python

2

Use the Python easy_install module to install the Flask web framework.
> easy_install Flask

This command correctly sets the environment variables.

Registering an external storage provider
Before you complete the steps in this section, do the following:
■

Have the fully qualified domain name (FQDN) of the external storage provider
server ready. See your export administrator for details. You can only register
one external storage provider with HyperScale.
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■

Disable the firewall on the external storage provider node or open port 8334.

■

Data nodes should be enabled. The external storage provider host using the
data management IP address.

To register an external storage provider

1

Navigate to HyperScale > System > Backup/Export Providers.

2

On the Backup/Export Providers page, click Register Provider.

3

In the Register External Storage Provider dialog box, do the following:

4

■

Use the Type drop-down list to select HyperScaleESP.

■

In the Storage server field, enter the fully qualified domain name (FQDN)
of the external storage provider server.

■

Enter the storage server password and OpenStack password in their
respective fields.

Click Register.
After the external storage provider is registered, it is listed on the
Backup/Export Providers page.
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Creating and exporting a snapshot
As an infrastructure administrator, you can create new instance snapshots for
instances running in your HyperScale deployment and export these snapshots to
the external storage provider node. A temporary copy of the instance snapshot is
created on the primary/secondary data node for the duration of the export operation.
Creating and exporting a snapshot has almost no impact on the I/O performance
of the instance you export.
This is just one of the external storage provider features that can help you protect
your instances against:
■

System failure

■

Data corruption due to software issues

■

User errors

The external storage provider can also aid you in disaster recovery.
For more information on external storage provider features, see the HyperScale
for OpenStack Installation Guide.
To create and export a snapshot

1

Navigate to Admin > System > Instances.

2

In the Instances table, find the instance you want to create a snapshot for.
This example creates a snapshot for the instance VM1.
In the table row for that instance, use the Actions drop-down list to select
Create & Export Snapshot.
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3

On the Create & Export Snapshot dialog box, specify the name of the new
snapshot.

4

Click Create & Export.
HyperScale displays the Tasks page, where you can monitor the progress of
the export.

Exporting a copy of a snapshot
You can export a copy of an instance snapshot that you have already created.
To export a copy of a snapshot

1

Navigate to Admin > System > Images.

2

In the Images table, locate the snapshot that you want to export. In the Actions
column for that snapshot, select Export a copy from the drop-down list.

Launching an instance from an exported snapshot
You can launch a new instance from an instance snapshot that was previously
exported. This lets you put an instance into service quickly without specifying new
configuration values.
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To launch an instance from an exported snapshot

1

Navigate to Admin > System > Instances.

2

On the Instances page, click the name of the instance whose snapshot you
want to launch. This example launches an exported snapshot of VM1.

3

On the Instances detail page, select the Versions tab.

4

Click on the export you want to use to launch a new instance.

5

On the Launch VM from exported snapshot dialog box, in the Instance
name field, specify the name of the new instance to create. In this example,
the new instance name includes the date of the original snapshot.
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6

Click Launch VM.
HyperScale displays the Tasks page, where you can monitor the instance
creation.

7

Return to the Instances page. When the instance is the running state, it is
ready to use.

8

To launch (import) the instance, navigate to Admin > System > Exports, find
the new instance, and click Import.

Launching an export from a deleted instance
You can launch an export from an instance that was previously deleted, either from
the graphical user interface or command line. This feature lets you return a version
of an instance to service that you had previously removed
To launch a deleted instance from the graphical user interface

1

Navigate to Admin > System > Exports, find the new instance, and click
Import.

2

On the Import Export dialog box, specify the name of the instance.

3

Click Import.
HyperScale displays the Tasks page, where you can monitor the instance
creation.

To launch a deleted instance from the command line

1

List all the exports using following command line.
$ instancesnapshot-list-exports

2

Identify the export you want to use to launch a new instance. Take note of its
export ID.

3

Enter the following command and specify the export ID. If you need to restore
the instance to a different project that the one from which it was exported, also
specify the project ID.
$ instancesnapshot-launch-instance export_ID [project_ID]
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Export and import activity logs
Each export job and import (launching an instance from an export) job triggered
through the Create & Export Snapshot and Export a Copy options on HyperScale
user interface or command line are logged in separate folders.
HyperScale logs each export or import operation initiation request in the
/var/opt/VRTSofesp/logs/hyperscale-esp.log file.
For example, an export job initiation request is logged in the hyperscale-esp.log
as follows. (The formatting in your file will look slightly different.)
Log file location [/var/opt/VRTSofesp/logs/
Export_ID/export.log]
for export [Export_ID]

In this case, detailed job logs are written to
/var/opt/VRTSofesp/logs/JobID/export.log.

Similarly, an import (launch instance) job initiation entry is logged in the
hyperscale-esp.log as follows. (The formatting in your file will look slightly
different.)
Log file location [/var/opt/VRTSofesp/logs/imports/JobID/export.log
for Import [Import_ID]

Detailed logs for this import job are written to
/var/opt/VRTSofesp/logs/imports/JobID/export.log.

Changing the level of detail in log files
When you export snapshot data to an external storage provider, or when you launch
a virtual machine from exported data (an import operation), HyperScale writes data
to log files on the external storage provider node.
To access these log files, first go the file
/var/opt/VRTSofesp/logs/hyperscale-esp.log. This file includes the path to

each log file.
The log files are in the following formats:
■

/var/opt/VRTSofesp/logs/exports/JobID/export.log

■

/var/opt/VRTSofesp/logs/imports/JobID/import.log

You can specify how much information is included in these log files.
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To change the level of detail in log files

1

On the external storage node, stop the hyperscale-esp service.
> service hyperscale-esp stop

2

Navigate to the /opt/VRTSofesp/etc/esp-config file.

3

In this file, update the log-level parameter to one of the following:

4

lower

Provides basic operation information. It contains logs for all the error
conditions and information logs about the steps being executed, and success
or failure of each step in the flow of the program.

all

Provides detailed information about data transfer, token timeouts, and a large
amount of additional information logs that you may to diagnose issues. You
should only specify this log level when an issue occurs, and you can't
diagnose it with the lower level log information.

Start the hyperscale-esp service.
> service hyperscale-esp start

Purging exports to free up space on the external
storage provider server
If space on the external storage provider server runs low, you can delete older
exports to free up space.
Note: Exercise caution when you delete an export. After you delete it, you cannot
recover it.
To purge exports on the external storage provider server
◆

On the controller node, enter the following command.
# instancesnapshot-delete-export

Troubleshooting external storage provider issues
External storage provider error messages are written to the following log on the
external storage provider server:
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var/opt/VRTSofesp/logs/hyperscale-esp.log

Logs for individual export or import (also known as launching an instance) jobs are
written to a separate log file each time.
/var/opt/VRTSofesp/logs/exports/JobID/export.log
/var/opt/VRTSofesp/logs/imports/JobID/import.log

Unregistering an external storage provider
The external storage provider can only be registered with HyperScale deployment.
You must unregister the current provider in the following circumstances:
■

You decide to change external storage providers.

■

You want to move the current external storage provider to another HyperScale
deployment.

To unregister an external storage provider

1

Navigate to the HyperScale > System > Backup/Export Providers page.

2

On the Backup/Export Providers page, click Unregister.

3

On the Confirm Unregister Provider dialog box, enter the host password and
OpenStack password, and click Unregister.

You can now uninstall the external storage provider software.
See “Uninstalling the external storage provider” on page 38.

Uninstalling the external storage provider
Before you try to uninstall the external storage provider, make sure that you have
unregistered it.
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See “Unregistering an external storage provider” on page 38.
To uninstall the external storage provider

1

Navigate to HyperScale > System > Backup/Export Providers.

2

On the Backup/Export Providers page, verify that the status of the external
storage provider is unregistered.

3

In the Actions column, click Clear.
Note: This operation does not have a confirmation screen. When you click
Clear, the external storage provider is immediately uninstalled.

Even though the external storage provider software is uninstalled, the exported
snapshots remain on the external storage provider node.

External storage provider commands
In addition to the HyperScale user interface, you can enter a wide range external
storage provider commands from the controller node command line.
See “Vendor registration commands” on page 81.
See “Instance snapshot and restore from snapshot commands” on page 86.
See “Export and import commands” on page 87.
For a complete list of HyperScale commands, see the appendix.
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Protecting HyperScale
instances with NetBackup
This chapter includes the following topics:
■

About integrating NetBackup into your HyperScale environment

■

Setting up NetBackup

■

NetBackup integration requirements

■

Registering NetBackup with HyperScale

■

Creating backup policies in NetBackup for HyperScale workloads

■

Assigning a backup policy

■

Verifying the NetBackup integration

■

Restoring an instance from a backup

About integrating NetBackup into your HyperScale
environment
Integrating Veritas NetBackup into your Veritas HyperScale environment is a
collaboration between you, the HyperScale infrastructure administrator, and the
NetBackup administrator. Steps must be performed on both the NetBackup
Master/Media server and on HyperScale. For example, before you can register
NetBackup as a backup provider with HyperScale, the NetBackup administrator
must tell you the Media Server fully qualified domain name and password, the
OpenStack password, and the directory on the Media Server (also known as the
staging location) that temporarily stores the backups before they are ingested into
the NetBackup storage unit (STU) .
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Similarly, before the NetBackup administrator can create HyperScale backup
policies, you need to tell the backup administrator how often you want backups to
occur for each type of backup policy so that a staging location can be created with
the required amount of free space.
The following table shows each backup task in order, and who performs it.
Table 3-1

HyperScale and NetBackup tasks

This task ...

Is performed by ...

Setting up the
NetBackup administrator
NetBackup environment
See “Setting up NetBackup” on page 42.
Meeting installation
requirements

NetBackup administrator

Registering NetBackup
with HyperScale

HyperScale infrastructure administrator

See “NetBackup integration requirements” on page 43.

See “Registering NetBackup with HyperScale” on page 44.

Creating a backup policy NetBackup administrator
See “Creating backup policies in NetBackup for HyperScale
workloads” on page 46.
Assigning a backup
policy to an instance or
flavor

HyperScale infrastructure administrator

Verifying NetBackup
integration

HyperScale infrastructure administrator and NetBackup
administrator

See “Assigning a backup policy” on page 46.

See “Verifying the NetBackup integration” on page 48.
Restoring from a backup HyperScale infrastructure administrator
See “Restoring an instance from a backup” on page 48.

Note: This chapter focused on your tasks HyperScale infrastructure administrator.
It mentions the general tasks the NetBackup administrator must perform, but the
specific steps are beyond the scope of this guide.
For specific information, the NetBackup administrator should refer to Veritas
NetBackup 8.0 Administrator's Guide, Volume I. You can download the guide here.
You can also download a NetBackup software compatibility list here.
In this release, HyperScale is only qualified with NetBackup Version 8.
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Setting up NetBackup
The NetBackup administrator must set up a dedicated Media Server in the production
environment. The Media Server is used as a Backup Proxy.
Table 3-2

NetBackup Media Server requirements

Hardware

Requirement

RAM

32 GB minimum, 64 GB or higher recommended

Virtual CPUs

4 cores minimum, 8 cores recommended

Network speed

1 Gbps minimum, 10 Gbps recommended

Hardware type

Physical machine

Network interface cards 3 required
(NICs)
■ A 1 Gbps management NIC. Configure this NIC to be on the
same management subnet as the controller node.
■ A 1 Gbps (minimum) data NIC. 10 Gbps is recommended.
Configure this NIC to be on the same data subnet as the data
nodes.
■ A public network NIC to communicate with the NetBackup
Master Server.
Physical storage

Enough physical storage to maintain instance snapshots.
HyperScale maintains a full copy of an instance's vDisks and
metadata when it is exported to the external storage provider node.
For example, if you export five instances that have a total of 5 TB
of data written to their vDisks, the external storage provider node
requires 5 TB of storage.

Network

The firewall on the external storage provider node is disabled, or
port 8334 is open. (This must be verified before you try to register
the external storage provider from the HyperScale user interface.)

When the NetBackup administrator completes the configuration, HyperScale, the
NetBackup Media Server, and NetBackup Master Server should have the following
communication path.
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Figure 3-1

Communications between the HyperScale controller and data
nodes and NetBackup Media and Master servers

In addition, the NetBackup administrator must configure the directory path on which
HyperScale backups are stored; this is known as the staging location. This location
needs to be on a separate set of disks than that of the storage unit (STU) disks (in
case of a hard-disk backed STU).

NetBackup integration requirements
Note: This HyperScale release is only qualified with NetBackup Version 8.0.
To integrate NetBackup with HyperScale, the NetBackup administrator must verify
the following:
■

The NetBackup Media Server and Master Server must be installed. When you
install the servers, use the fully qualified domain names. Also use the fully
qualified domain name when you register the Media Server with the Master
Server.

■

The Media Server must be running Red Hat Enterprise Linux (RHEL) 7.2. The
"Minimal Install" is not supported; however, the RHEL software "Infrastructure
Server" and above are supported.

■

The firewall on the Backup Proxy node is disabled, or port 8443 is open. (This
must be verified before you try to register NetBackup from the HyperScale user
interface.)
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■

The date, time, and zone on the Backup Proxy node must be in sync with the
date, time, and zone on the Master Server. If the dates and times are not sync,
backups still occur, but they are not displayed on the HyperScale user interface.

After this information is verified, the NetBackup administrator must communicate
the following information to the HyperScale infrastructure administrator:
■

The Media Server fully qualified domain name.

■

The Media Server password.

■

The OpenStack password.

■

The directory path on which HyperScale backups are staged temporarily; this
is known as the staging location. This location needs to be on a separate set of
disks than that of the storage unit (STU) disks (in case of a hard-disk backed
STU).

Registering NetBackup with HyperScale
The HyperScale infrastructure administrator performs this task. When you register
NetBackup with HyperScale, the external storage provider (ESP) package is installed
and configured on the NetBackup Media Server (also known as the Backup Proxy
Server).
Before you perform the steps in this section, make sure that the NetBackup
administrator has given you the following information:
■

The NetBackup Media Server's management IP address. For security reasons,
the ESP package is registered with the management IP address, rather than
the public IP address. The data transfer is over the private network.

■

The NetBackup Media Server (Backup Proxy Server) password.

■

The path to the staging location on the NetBackup Media Server (Backup Proxy
Server) where HyperScale backups will be stored.

The NetBackup administrator must also disable the firewall on the Backup Proxy
node, or open port 8443.
You also need the OpenStack password for the HyperScale environment.
Before you register NetBackup, data nodes must be enabled.
Registering NetBackup with HyperScale

1

Navigate to HyperScale > System > Backup/Export Providers.

2

On the Backup/Export providers page, click Register.

3

On the Register Providerr dialog box, do the following:
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4

■

In the Type field, use the drop-down list to select NetBackup.

■

Complete the rest of the fields using the information you gathered above.

Click Register. HyperScale displays the Backup/Export providers page,
where you can follow the progress of the installation.
Note: The ESP package is automatically installed on the Media Server. No
NetBackup administrator action is required.

5

When the registration completes, refresh the Backup/Export providers screen.
NetBackup is now listed. The server name shows the fully qualified domain
name of the NetBackup Media Server.
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Creating backup policies in NetBackup for
HyperScale workloads
The NetBackup administrator performs this task. You should gather the following
information from the HyperScale user interface about the registered backup provider
and give it to them:
■

The fully qualified domain name used at the time of registration

■

Backup selection path (internally generated by HyperScale based on the staging
path you specified at the at the time of registration)

Assigning a backup policy
This task is performed by the HyperScale infrastructure administrator. The backup
policy defines when and how often an instance is backed up. You can assign a
policy to multiple instances or flavors at the same time.
To assign a backup policy to an instance

1

On the Backup Policies page, select the policy you want to apply. Under the
Actions drop-down list, select Assign/Update.

2

On the Assign/Update <name> policy to instances page, you have the
following options in the drop-down list:
■

Name

■

Status

■

Flavor

You can use a combination of these options to select your instances. For
example, you could select the name as VM. The regular expression is "contains"
rather than "equal to," so that all instances that contain the string VM are a
match.
You could filter the results further by specifying the flavor as VRTSBronze.
You can choose the flavors from the drop-down list.
The relationship between the two regular expressions is AND. The example
above lists instances whose name contains the string VM AND that also have
the VRTSBronze flavor.

46

Protecting HyperScale instances with NetBackup
Assigning a backup policy

3

Click Run to list the instances that match your criteria.

4

Review the list of instances. If these are the instances to which you want to
assign the policy, click Assign Policy; otherwise, click Back to modify your
regular expressions.

5

When the policy is assigned successfully, a confirmation screen is displayed.

Click Close.
Now, when a backup is triggered from NetBackup, the instances that are associated
with the policy are backed up. Any instances that are created later that match the
regular expressions are also backed up.

47

Protecting HyperScale instances with NetBackup
Verifying the NetBackup integration

Verifying the NetBackup integration
This task is performed by the HyperScale infrastructure administrator. To verify that
NetBackup is successfully integrated with HyperScale, the NetBackup administrator
triggers a manual backup. Both administrators can monitor the progress of the
backup on the respective user interfaces.
Note: Do not start a backup during a live migration. Wait until the live migration
completes.
To verify NetBackup integration on HyperScale
◆

Navigate to Project > Compute > Tasks page. You can see that backup has
been triggered. While the backup runs, the status is Creating. When the backup
finishes, the status is Completed.
Note: If a backup fails, it is not shown on the Backups tab. However, the Tasks
page shows that the backup is in the Failed state.

Restoring an instance from a backup
This task can be performed by both the HyperScale infrastructure administrator as
well as a HyperScale tenant/project user. Restoring a backup to a new instance
lets you quickly create a virtual machine from a previous point in time. This is
especially useful if an instance has failed and you need to get a version of it back
in service quickly.
The infrastructure administrator can restore from backup for any tenant. The backup
can be restored only to the tenant to which the virtual machine belonged at the time
of backups. Cross-tenant restores are not supported. You can restore an instance
from a backup using the backup list or the instance version time line.
A tenant user can only see and restore from backup images only for their own
tenancy.
To restore from a backup on the backup list

1

Navigate to Project > Compute > Backups.

2

In the list of backed up instances, locate the one that you want to restore, and
click Restore.
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3

On the Restore Backup dialog box, in the Instance name field, enter a new
instance name. This instance is created from the backed-up version.
Note: The new instance name cannot contain any spaces.

4

Click Restore. HyperScale takes you to the Project > Compute > Tasks page
so you can verify that the instance is being created. The instance is initially in
the Initiated state. It then moves the Creating state, and finally to the
Completed state.

To restore from a backup on the version time line

1

Navigate to Admin > System > Instances.

2

In the list of instances, click the name of the instance whose backup you want
to restore.

3

On the instance details page, Versions tab, select the backup you want to
restore from the time line. At the bottom of the time line is a light gray bar you
can use to horizontally scroll the time line to find your backup.

4

Click the icon for the backup you want to restore.
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5

On the Restore from Backup dialog box, in the Instance name field, enter a
new instance name. This instance is created from the backed-up version.

6

Click Restore. HyperScale takes you to the Project > Compute > Tasks page
so you can verify that the instance is being created. The instance is initially in
the Initiated state. It then moves the Creating state, and finally to the
Completed state.
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Ensuring predictable
performance
This chapter includes the following topics:
■

Changing quality of service (QoS) parameters from the command line

Changing quality of service (QoS) parameters
from the command line
HyperScale ensures that your virtual machines perform at a consistent quality of
service (QoS). Two parameters (miniops and maxiops) define the minimum and
maximum number of I/Os per second (IOPS) for the vDisk. To define the QoS for
your virtual machine, you can do one of the following:
■

Assign it a HyperScale flavor, which includes minimum and maximum IOPS
values.

■

Set (or change) the miniops and maxiops values from the command line using
the hyperscale qos-sla-update command.

This section describes the second approach.
The format of the hyperscale qos-sla-update command is:
hyperscale qos-sla-update [--miniops min_iops] \
[--maxiops max_iops] vdisk_id

To change the quality of service parameters from the command line

1

Obtain the ID of the vDisk whose QoS you want to change.
■

Navigate to Project > Compute > Volumes.

■

In the Volumes table, click the instance name.

Ensuring predictable performance
Changing quality of service (QoS) parameters from the command line

■

2

On the Volumes details page, on the Overview tab, note the ID. That is
the vDisk ID to use.

Run the hyperscale qos-sla-update to modify one or both of the QoS
parameters. For example, the following command sets the minimum IOPS for
the vDisk to 100.
# hyperscale qos-sla-update --miniops 100 \
01310622-28a9-4fa1-bcb7-9c3d4dea8765

The following command sets the maximum IOPS to 1000.
# hyperscale qos-sla-update --maxiops 1000 \
01310622-28a9-4fa1-bcb7-9c3d4dea8765
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5

Compute node and data
node resiliency
This chapter includes the following topics:
■

Compute node resiliency

■

Data node resiliency

Compute node resiliency
In the compute plane, HyperScale provides resiliency for the following types of
failures:
■

Storage service failure

■

Reduced reflection factor

■

Storage media failure

If any of these failures occur, an alert is displayed in the Alerts/Events area of the
HyperScale dashboard (HyperScale > System > Overview).
For known issues related to HyperScale compute node resiliency, see "Compute
node issues" in the HyperScale Release Notes.

Storage service failure
If the HyperScale compute daemon (hscd) fails on a compute node that hosts virtual
machines, HyperScale automatically provides storage resiliency for those virtual
machines. No administrator action is needed.
The applications running inside the virtual machines do not encounter any timeouts
or errors, and HyperScale recovers the storage. This ensures that there is no
downtime for the virtual machines and applications.
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Reduced reflection factor
HyperScale maintains data resiliency on the compute nodes through a method
called reflection. When I/O occurs on a virtual machine, it is not only written on the
source compute node, but is also written (or reflected) to at least one other compute
node in the deployment. These additional compute nodes are called reflection
targets, and the number of reflection targets used is the reflection factor.
A virtual machine's reflection factor, depends on which HyperScale flavor you assign
to it. To use reflection, a virtual machine must have one of the following flavors.
HyperScale flavors and reflection factors

Table 5-1
Flavor

Reflection factor

VRTSSilver

1
Data is written to one reflection target.

VRTSGold

2
Data is written to two reflection targets.

If storage on a reflection target fails, HyperScale provides resiliency to restore the
reflection target. It automatically tries to restore the reflection factor by creating a
reflection copy on another compute node. You can check the restoration process
by entering the following command:
# hyperscale reflection-restore-status instance_uuid

instance_uuid is the OpenStack instance ID. You can find the instance ID by doing
the following:
1.

Navigate to Admin > System > Instances.

2.

Click on the instance you are interested in.

3.

On the Instances details page, noting the string in the ID row.

Resiliency is supported for following types of storage failures on the reflection target
node:
■

Storage service
If the storage service fails on the reflection target of a virtual machine, restoration
occurs on another available compute node. If another compute node is not
available, HyperScale retries on the same compute node by recovering the
compute storage service.

■

Media failure
If a solid-state drive (SSD) or hard disk drive (HDD) fails on a reflection target,
restoration occurs on an available compute node.
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In some cases, you must manually restore the reflection factor when a functioning
compute node is available. These situations include the following:
■

When you restart a crashed storage agent

■

When you add a new compute node

To manually restore reflection, enter the following command:
# hyperscale reflection-restore instance_uuid

Storage media failure
If an SSD or HDD fails on a compute node that hosts virtual machines, HyperScale
provides resiliency of storage for the virtual machines on that compute node. No
administrator action is needed. The applications running inside the virtual machines
do not encounter any timeouts or errors. HyperScale serves IOs from the reflection
compute nodes.
Later, you can perform a live migration of the virtual machines on the compute node
that has the media failure. This ensures that there is no downtime for the virtual
machines and applications.

Data node resiliency
The HyperScale data node acts as a secondary storage tier for storing vDisk
versions. vDisk versions are periodically synchronized with the data node. If a
compute node fails, the vDisk version is read from the data node. For a vDisk having
the VRTSSilver flavor and above, data is reflected from one data node (primary)
to another data node (secondary).
HyperScale provides resiliency at data plane in case of following data node failures.
There is minimal impact on applications and data management services such as
snapshots and recoveries. Alerts are raised for all these failures in the Alerts/Events
area of the HyperScale dashboard (HyperScale > System > Overview).
■

Storage media failure
If a data node's solid-state drive (SSD) or hard disk drive (HDD) fails, ongoing
snapshots are aborted, and the data node goes into the Down state. You must
remove the data node from the configuration. After you replace the faulty disk,
re-add the same data node in the configuration.
See “Removing a data node” on page 19.
See “Adding a data node” on page 14.

■

Data network failure
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If the data node's data network card or data network cable fails, the data node
cannot communicate with the controller. The data node goes into the Down
state. After you fix the network communication issue, remove the data node
from the configuration and add it again.
■

Storage service failure
If the storage service (hyperscale-dmld) fails, the data node goes into the
Down state. You can remove failed data node and add a new one or fix the
existing node and add it again.

■

If the compute node cannot send episodic data synchronization messages to
the primary data node.

In each of these failures, the vDisks associated with the failed data node are marked
as resiliency degraded and its ownership is transferred automatically to a peer data
node. The peer data node starts serving the next snapshots and recovery reads.
Any ongoing requests at the time of failure restart on the new primary data node
after the ownership change.
To restore the reflection back for degraded vDisks, you must remove the failed data
node, replace it, and perform a data node synchronization.
For more information, see the section synchronizing a data node.
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Configuring multi-rack
resiliency
This chapter includes the following topics:
■

About HyperScale support for multi-rack deployments

■

How HyperScale provides multi-rack resiliency

■

How to configure HyperScale for multi-rack resiliency

■

Administering rack information in a HyperScale configuration

■

Multi-rack command logs

About HyperScale support for multi-rack
deployments
When thinking about private cloud deployments using OpenStack, there are multiple
parameters that need consideration before the actual provisioning activity begins.
Increasingly demanding nature of workloads not only require scaling in terms of
processing power, memory, and storage, but adding resiliency capabilities so that
the configuration is able to withstand planned and unplanned downtime becomes
equally important.
One of the methods to tackle software and hardware failures is to physically
segregate server deployment using multiple racks. For example, you can deploy
the Controller on a separate rack and spread the compute nodes across two or
more racks. These racks can be placed adjacent to each other in a single area or
across multiple sites.
In case of a failure such as an instance failure, a compute or data node failure, or
a hardware malfunction resulting in a complete rack failure, the alternate racks
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provide active redundancy and are ready to handle the additional workloads, until
the failure condition is resolved and the failed setup is brought back online. The
intent of such a design is to provide resiliency and prevent having single points of
failure in the configuration.
HyperScale supports such multi-rack OpenStack deployments wherein compute
and data nodes are spread across two or more racks with the Controller node
residing on a separate rack or on one of the compute node racks.

How HyperScale provides multi-rack resiliency
HyperScale provides a set of commands that you can use to associate compute
nodes with the racks on which the nodes are deployed. This association is referred
as “tagging". When all the computes in a HyperScale configuration are tagged with
their respective rack information, the configuration is considered as enabled for
rack resiliency. HyperScale uses this rack resiliency status while determining where
to create reflection targets for eligible instances (Silver and Gold flavors) running
on the computes on each rack.
To achieve data resiliency for Gold and Silver instances running on compute nodes,
each instance I/O is written to the source compute node (that is the node that hosts
the instance) and at least one other additional compute node. This process is called
as reflection and the additional compute node is called as a reflection target. The
reflection target is another compute node on the same rack as the source node or
a compute node deployed on a separate rack altogether. HyperScale chooses
reflection targets based on the overall workload distribution and compute node
capacity.
In case of a rack resilient configuration, the reflection targets for all eligible instances
always reside on a different rack. HyperScale picks a target compute node from an
alternate rack and ensures that it is not on the same rack as where the source
compute node is deployed. Data resiliency is thus achieved using a "rack-resilient"
configuration that spans across multiple racks and is better prepared to deal with
single points of failure.
HyperScale treats a configuration as enabled for rack resiliency only if all the
computes within the configuration are tagged. Rack resiliency is not determined at
a rack level. If one compute on a rack is not associated with its respective rack
information, the configuration is not considered as rack-resilient, even if all the
computes on another rack are tagged.
Figure 6-1 shows a typical HyperScale multi-rack deployment consisting of two
racks—Rack-A and Rack-B, each hosting four compute nodes and one data node.
The Controller node resides on Rack-A, however it can also reside on Rack-B or
any other additional rack, as long it is on the same subnet.

58

Configuring multi-rack resiliency
How HyperScale provides multi-rack resiliency

Figure 6-1

Typical multi-rack configuration
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Compute nodes C1, C2, C3, and C4 are tagged with Rack-A while C5, C6, C7, and
C8 are tagged with Rack-B. As all the computes are tagged with their respective
rack information, all the instances created in this configuration are rack-resilient.
If a silver instance is created on compute node C1, HyperScale creates a reflection
target on any of the compute nodes on Rack-B. For a Gold instance on C2,
HyperScale creates two reflection targets on two separate compute nodes, with at
least one of the target compute node residing on Rack-B. Similarly, any eligible
instances on the compute nodes on Rack-B have at least one reflection target
designated on Rack-A.
In a deployment with only a few compute nodes configured, HyperScale ignores
the flavor settings and creates only that many reflection targets as the number of
available and eligible compute nodes. For example, if there is only one compute
node in each rack, then for a Gold instance, even though the reflection factor is two
(which means data needs to be reflected to at least two additional compute nodes),
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HyperScale creates only one reflection target, either on the same rack or a different
rack, depending on the rack resiliency status of the configuration.

How to configure HyperScale for multi-rack
resiliency
Configuring HyperScale for multi-rack resiliency involves the following tasks:
1.

Adding rack information to the configuration

2.

Associating (or tagging) compute nodes with the respective racks

Prerequisites for configuring rack resiliency
The following details are required while configuring multi-rack resiliency:
■

Rack names

■

Rack descriptions

■

Site names

■

Controller node IP address

■

Controller node admin user name and password

Note: A minimum of two racks are required for rack resiliency to take effect in a
HyperScale multi-rack configuration. All the racks that are part of the multi-rack
configuration must belong to the same subnet.
Figure 6-2 shows the steps required to configure HyperScale for multi-rack resiliency.
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Figure 6-2
STEP 1

STEP 2

ControllerAdmin

61

Multi-rack resiliency configuration steps
BEFORE YOU BEGIN
Keep the following details at hand:
Rack names, Rack descriptions
Site names
Controller IP address and admin user credentials

CONNECT TO THE CONTROLLER NODE
1. Connect to the Controller node using admin credentials:
# ssh <Controlleradminuser>@<ControllerIPaddress>
2. Set the default environment for authentication:
# source keystonerc_admin

STEP 3

ADD RACK DETAILS
Add rack details to the configuration, one rack at a time:
# hyperscale rack-add <rackname> --site_name <sitename> --desc <rackdescription>
<rackname> is mandatory. Use quotes if input parameter values contains spaces.
STEP 4

x-y-z

a-b-c

VIEW RACK IDs
Make a note of the unique rack ID assigned to each rack:
# hyperscale rack-list
Refer to the entries in the [rack_id] column.

STEP 5
x-y-z
a-b-c

TAG COMPUTE NODES WITH RACKS
Associate each compute node with its respective rack, one node at a time:
# hyperscale node-tag-rack <computenodenameorIPaddress> <rack_id>

STEP 6

VERIFY HYPERSCALE CONFIGURATION
Check that the rack details are accurately updated:
# hyperscale nodes
Refer to the entries in the [personality] and [rack_id] columns.

Once the rack information is updated in the HyperScale configuration, instances
(virtual machines) that are created thereafter are automatically treated as rack
resilient. While determining reflection targets for rack-resilient instances, HyperScale
uses the rack information to choose appropriate compute nodes from alternate
racks.
See “How HyperScale provides multi-rack resiliency” on page 58.
See “Administering rack information in a HyperScale configuration” on page 62.
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Administering rack information in a HyperScale
configuration
Use the commands described in this section to perform administrative tasks on
your multi-rack HyperScale configuration. Each command is described along with
the syntax and usage, followed by an example.

Add rack information to the HyperScale configuration
Run the following command on the HyperScale Controller node:
# hyperscale rack-add <rack_name> --site_name <sitename> \
--desc <rackdescription>

Here, <rack_name> is mandatory. The other parameters are optional. Use quotes
if the parameter input values contain empty spaces.
To view inline help about the command, type the following:
# hyperscale help rack-add

Example 1
Add a rack named “Rack-Alpha” belonging to a site named “Site-Charlie” and put
the description as “Primary-rack-Alpha”:
# hyperscale rack-add Rack-Alpha --site_name Site-Charlie \
--desc Primary-rack-Alpha

Example 2
Add a rack named “Rack Alpha” belonging to a site named “Site Charlie” and put
the description as “Primary rack: Alpha”:
# hyperscale rack-add "Rack Alpha" --site_name "Site Charlie" \
--desc "Primary rack: Alpha"

Delete rack information from the HyperScale configuration
Run the following command on the HyperScale Controller node:
# hyperscale rack-remove <rack_id>

Here, rack_id is a unique identifier key that HyperScale assigns to a rack to identify
it in the configuration. A random but unique identifier key is automatically allotted
as soon as a rack is added to the configuration and represents the rack as long as
it remains in the HyperScale configuration.
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When you remove a rack from the configuration, the unique identifier associated
with it gets purged and is never used again. Even if the rack associated with the
identifier is removed and added back in to the configuration, the earlier key is never
used again.
Note: You cannot delete rack details from the configuration if there is at least one
compute node associated with the rack.
To view inline help about the command, type the following:
# hyperscale help rack-remove

Example
Remove rack with rack id “53a354f3-9af8-410e-88d0-3332f3c15191”:
# hyperscale rack-remove 53a354f3-9af8-410e-88d0-3332f3c15191

Update rack information in the HyperScale configuration
Run the following command on the HyperScale Controller node:
# hyperscale rack-update rack_id --rack_name <rackname> \
--site_name <sitename> --desc <rackdescription>

Here, rack_id is mandatory. You cannot modify any rack information without
specifying the rack identifier in the command.
This command modifies details of the rack that is added to the HyperScale
configuration. You can modify the rack name, the site name, and the description,
in any order, in a single command. You can also modify each of these parameters
individually using a separate command.
To view inline help about the command, type the following:
# hyperscale help rack-update

Example 1
Modify name of rack with rack id “53a354f3-9af8-410e-88d0-3332f3c15191” to
“Rack-Beta”, assign it to site “Site-Tango”, and put the description as
“Secondary-rack-Beta”:
# hyperscale rack-update 53a354f3-9af8-410e-88d0-3332f3c15191 \
--rack_name Rack-Beta \
--site_name Site-Tango \
--desc Secondary-rack-Beta
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The same result can also be achieved using the following command (note that the
order of the parameters is reversed):
# hyperscale rack-update 53a354f3-9af8-410e-88d0-3332f3c15191 \
--desc Secondary-rack-Beta \
--site_name Site-Tango \
--rack_name Rack-Beta

Example 2
Modify name of rack with rack “id 53a354f3-9af8-410e-88d0-3332f3c15191” to
“Rack-Gamma”:
# hyperscale rack-update 53a354f3-9af8-410e-88d0-3332f3c15191 \
--rack_name Rack-Gamma

Example 3
Modify the description of rack with rack “id 53a354f3-9af8-410e-88d0-3332f3c15191”
to “Standby rack: Gamma”:
# hyperscale rack-update 53a354f3-9af8-410e-88d0-3332f3c15191 \
--desc "Standby rack: Gamma"

Associate a compute node with a rack
Run the following command on the HyperScale Controller node:
# hyperscale node-tag-rack <computenodenameorIP> <rack_id>

Associating a compute node with a rack, also referred to as tagging, is required for
rack resiliency to take effect. You can perform this task only after you add the rack
information to the configuration.
To view inline help about the command, type the following:
# hyperscale help node-tag-rack

Example 1
Tag node “Alpha-compute1.veritas.com” with rack with rack id
“53a354f3-9af8-410e-88d0-3332f3c15191”:
# hyperscale node-tag-rack Alpha-compute1.veritas.com \
53a354f3-9af8-410e-88d0-3332f3c15191

Example 2
Tag node “77.206.105.132” with rack with rack id
“53a354f3-9af8-410e-88d0-3332f3c15191”:
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# hyperscale node-tag-rack 77.206.105.132 \
53a354f3-9af8-410e-88d0-3332f3c15191

View list of racks and their rack IDs
Run the following command on the HyperScale Controller node:
# hyperscale rack-list

The output displays information similar to the following:
+--------------------------+-----------+-------------+---------------+
| rack_id
| rack_name | site_name
| description
|
+--------------------------+-----------+-------------+---------------+
| 1510-3fb5-47b5-ba7f-41ab | Rack-Beta | Site-Tango | Secondary-Beta|
| 3b6c-bb16-4050-ade8-e935 | Rack-Gamma| Site-Tango | None
|
| 5335-9af8-410e-88d0-3332 | Rack-Alpha| Site-Charlie| Primary-Alpha |
+--------------------------+-----------+-------------+---------------+

You can also run the following command to see the list of compute nodes and the
assigned rack details:
# hyperscale nodes

The output displays a lot more information about the systems in your HyperScale
configuration. This includes the host ID, host name, data IP address, network IP
address, node personality type, status, hypervisor ID, version and rack ID.

View rack resiliency status for an instance
After you tag the compute nodes with their respective racks, all instances that are
launched thereafter display the rack resiliency status as part of their metadata
information. Use the HyperScale dashboard to view the rack resiliency status for
an instance.
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To view the rack resiliency status for an instance

1

Log on to the HyperScale dashboard using OpenStack admin user credentials.
Use the following URL:
https://<controllerIPaddress>/horizon/auth/login

2

Navigate to Project > Instances.
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3

From the Instances table, under the Instance Name column, click on an instance
name to view its information.

4

On the Overview tab, scroll to the Metadata section.
The rack_resiliency field value indicates the status of rack resiliency for the
instance.
Rack resiliency
status

Description

Not applicable

For instances associated with Gold or Silver flavors, this status
indicates that one or more compute nodes in the configuration
are not tagged with any rack information.
Even if the instance itself is running on a tagged compute, the
fact that at least one compute node is not tagged results in this
status. The configuration is therefore not treated as rack
resilient.

Note: Instances associated with bronze flavor display this
status as there is no reflection factor for bronze instances.
Healthy

Indicates that the configuration is rack resilient.

Degraded

A degraded status indicates that eligible compute nodes are
not available on the alternate rack. The reflection target for the
computes are therefore created on available computes on the
same rack where the source compute node is located.
Even though the configuration is treated as rack resilient, the
reflection targets are created on the source rack due to a lack
of compute nodes on another rack.

Multi-rack command logs
When you run HyperScale commands to configure and administer a multi-rack
HyperScale configuration, the command output confirms whether or not the
command was successful.
For example, when you run the following command to add a rack:
# hyperscale rack-add Rack-Alpha

The output confirms that the command was successful:
+----------+--------------------------------------+
| Property | Value
|
+----------+--------------------------------------+
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| response | Rack - Rack-Alpha added successfully |
+----------+--------------------------------------+

However, if a command fails for some reason, the output confirms the failure and
also displays the reason for the failure.
For example, when you run the following command to remove a rack:
# hyperscale rack-remove c02-c3d2-42-8c54-d7b

The output confirms why the command failed:
+----------+-----------------------------------------------------+
| Property | Value
|
+----------+-----------------------------------------------------+
| response | No rack id - c02-c3d2-42-8c54-d7b found in database |
+----------+-----------------------------------------------------+

In some cases, the command output displays an HTTP 500 error that resembles
the following:
ERROR: The server has either erred or is incapable of performing the
requested operation. (HTTP 500)
(Request-ID: req-bb7f5104-abcd-efgh-34hijk33lmno)

All multi-rack command logs are maintained in the HyperScale api log file at the
following location:
/var/opt/VRTSofmn/logs/hyperscale-api.log

You can also refer to the following log file to get more details:
/var/opt/VRTSofcore/logs/controller.log
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Performing a live migration
This chapter includes the following topics:
■

Configuring OpenStack to support HyperScale live migration

■

Performing a live migration

Configuring OpenStack to support HyperScale
live migration
To perform live migrations in HyperScale, you must make the following changes to
the OpenStack configuration.
Table 7-1

OpenStack configuration changes to support HyperScale live
migration

For this item ...

Make this change ...

nova.conf

rpc_response_timeout = 180
(The default is 60.)

cinder.conf

rpc_response_timeout = 180
(The default is 60.)

MySQL

Max Connections = 2048
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Table 7-1

For this item ...

OpenStack configuration changes to support HyperScale live
migration (continued)
Make this change ...

RabbitMQ configuration Add the following lines:
file
[binary,
{packet, raw}
,
{reuseaddr, true}
,
{backlog, 128}
,
{nodelay, true}
,{linger,{true,0}},
{exit_on_close, false}
,
{sndbuf,32768}
,
{recbuf,32768}
,
{keepalive, true}
]}

Performing a live migration
A live migration moves an instance from one host to another without any interruption
of service. Currently, you can only live migrate one instance at a time, and
HyperScale determines the host the instance is migrated to.
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To perform a live migration

1

Navigate to Admin > System > Instances.

2

In the table on the Instances page, locate the host that is running the instance
you want to live migrate. This example uses host sdsr720-09 and migrates
instance VM1.
Use the Actions drop-down list to select Live Migrate Instance.

3

Live Migrate dialog box shows the Current Host for the virtual machine.
Click Submit.

4

HyperScale updates the Instances page Status column as the migration
occurs. Note that the instance is on a different host, sdsr720-02.
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Troubleshooting
This chapter includes the following topics:
■

HyperScale alerts reference

■

About HyperScale log files

■

Synchronizing data node reflection after a failure

■

Handling a data node failure due to a disk fault

■

Recovering a compute node after a storage media failure

■

Handling controller node reboot failures

■

HyperScale nodes status shows as up even if one or more OpenStack services
are down

HyperScale alerts reference
The Alerts area of the HyperScale dashboard displays information or errors that
you may need to take action on. This section list each HyperScale alert and its
accompanying text. Variable strings being with a percent sign are replaced with the
text relevant to your situation, such as the name of a compute node or a storage
device.
Table 8-1
Alert name

Text

alert.cloud.cache.ssdthres

SSD usage on %(ASSOC)s high

alert.cloud.cache.ssdthresl2

SSD usage on %(ASSOC)s reached 70 percent

alert.cloud.compute.down

Compute %(ASSOC)s service is down
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Table 8-1

(continued)

Alert name

Text

alert.cloud.dal.ioerror

I/O error on compute %(ASSOC)s

alert.cloud.disk.removed

Disk from Compute %(ASSOC)s is removed. Please
live migrate any existing instances from this Compute
and perform Disable and Enable operations to re-use
this compute

alert.cloud.dn.down

Datanode %(ASSOC)s service is down

alert.cloud.dnsl.ioerror

I/O error on datanode %(ASSOC)s

alert.cloud.eds.failed

Snapshot creation failed for compute %(ASSOC)s due
to network connection failure

alert.cloud.hdd.failed

I/O error occurred on vdisk associated with compute
%(ASSOC)s. Use vxdisk list command to know the failed
HDDs

alert.cloud.poolutil.exceeded

%(ASSOC)s is using more than 90 percent of its storage

alert.cloud.qos.miniops

Cannot serve miniops for compute %(ASSOC)s

alert.cloud.ssd.failed

SSD I/O error on %(ASSOC)s. Use vxdisk list command
to know the failed SSDs

alert.cloud.vm.failed

VM has failed on compute %(ASSOC)s due to storage
daemon restart

alert.compute.cache.ssdthres

SSD usage on %(SOURCE)s high

alert.compute.cache.ssdthresl2

SSD usage on %(SOURCE)s reached 70 percent

alert.compute.dal.ioerror

I/O error on VM %(ASSOC)s in compute %(SOURCE)s

alert.compute.disk.removed

Disk %(ASSOC)s from Compute %(SOURCE)s is
removed. Please live migrate any existing instances
from this Compute and perform Disable and Enable
operations to re-use this compute

alert.compute.eds.failed

Snapshot creation failed for VM %(ASSOC)s in compute
%(SOURCE)s due to network connection failure

alert.compute.hdd.failed

I/O error occurred on vdisk associated with compute
%(SOURCE)s. Use vxdisk list command to know the
failed HDDs
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Table 8-1

(continued)

Alert name

Text

alert.compute.qos.miniops

Cannot serve miniops for VM %(ASSOC)s in compute
%(SOURCE)s

alert.compute.service.down

Compute %(SOURCE)s service is down

alert.compute.snapshot.failed

Episodic snapshot creation failed for tenant
%(TENANT)s and compute %(SOURCE)s for Instance
%(ASSOC)s. Please ensure that there are no quota
restrictions for creating snapshots

alert.compute.ssd.failed

SSD I/O error on %(SOURCE)s. Use vxdisk list
command to know the failed SSDs

alert.compute.vm.failed

VM has failed on compute %(ASSOC)s due to storage
daemon restart

alert.dn.dnsl.ioerror

I/O error on datanode %(SOURCE)s

alert.dn.poolutil.exceeded

%(SOURCE)s is using more than 90 percent of its
storage

alert.dn.service.down

Datanode %(SOURCE)s service is down

alert.vdisk.bst.failed

BST hydrate workflow failed for vdisk %(SOURCE)s

alert.vdisk.dal.ioerror

I/O error on vdisk %(SOURCE)s

alert.vdisk.dnrs.failed

Datanode reflection failure for vdisk %(ASSOC)s

alert.vdisk.dnrt.failed

Datanode reflection failure for vdisk %(ASSOC)s

alert.vdisk.eds.failed

Snapshot creation failed for vdisk %(SOURCE)s due to
network connection failure

alert.vdisk.qos.miniops

Cannot serve miniops for vdisk %(SOURCE)s

alert.vdisk.ror.failed

RoR workflow failed for vdisk %(SOURCE)s

alert.vdisk.smf.failed

SMF workflow failed for vdisk %(SOURCE)s

alert.vdisk.snapshot.failed

Episodic snapshot creation failed for tenant
%(TENANT)s and vdisk %(SOURCE)s. Please ensure
that there are no quota restrictions for creating
snapshots

alert.vdisk.ssf.failed

SSF workflow failed for vdisk %(SOURCE)s
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Table 8-1

(continued)

Alert name

Text

alert.vm.bst.failed

BST hydrate workflow failed for vdisk %(ASSOC)s
associated with instance %(SOURCE)s

alert.vm.cnrt.failed

Storage Redundancy SLA is violated for an Instance
"%(SOURCE)s". Refer to hyperscale cli option to get
the current status of storage redundancy level

alert.vm.dal.ioerror

I/O error on vdisk %(ASSOC)s in VM %(SOURCE)s

alert.vm.degraded.dn.sla

VM %(SOURCE)s is not able to meet resiliency SLAs
for snapshots due to datanode failure

alert.vm.dnror.failed

Failed to restore Datanode resiliency for vdisk
%(ASSOC)s

alert.vm.dnrt.failed

Datanode reflection failure for vdisk %(ASSOC)s in VM
%(SOURCE)s

alert.vdisk.eds.failed

Snapshot creation failed for vdisk %(SOURCE)s due to
network connection failure

alert.vm.failed

VM %(SOURCE)s has failed due to storage daemon
restart

alert.vm.qos.miniops

Cannot serve miniops for vdisk %(ASSOC)s in VM
%(SOURCE)s

alert.vm.ror.failed

RoR workflow failed for vdisk %(ASSOC)s associated
with instance %(SOURCE)s

alert.vm.smf.failed

SMF workflow failed for vdisk %(ASSOC)s associated
with instance %(SOURCE)s

alert.vm.snapshot.failed

Episodic snapshot creation failed for tenant
%(TENANT)s and Instance %(SOURCE)s for vdisk
%(ASSOC)s. Please ensure that there are no quota
restrictions for creating snapshots

alert.vm.ssf.failed

SSF workflow failed for vdisk %(ASSOC)s associated
with instance %(SOURCE)s

About HyperScale log files
HyperScale includes one or more log files for the following components.
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Table 8-2

Controller logs

Log file

Contents

/var/opt/VRTSofcore/logs/ofengine.log

Installation information.

/var/opt/VRTSofcore/logs/<datanode_mgmtIP>_config.log Information about add and
remove operations performed on
a data node.
/var/opt/VRTSofcore/logs/<computenode_mgmtIP>_config.log Information about enable and
disable HyperScale operations
performed on a compute node.
/var/opt/VRTSofcore/logs/controller.log

Information about all HyperScale
tasks.

/var/opt/VRTSofcore/logs/default.log

Statistics logs.

/var/opt/VRTSofmn/logs/zookeeper.log

Zookeeper service logs.

Table 8-3

Compute node logs

Log file

Contents

var/opt/VRTSofcore/logs/hypervisor.log

HyperScale MQ service logs on
the compute node.

var/log/hypervisor.log

Compute storage service logs.

Table 8-4

Data node logs

Log file

Contents

/var/opt/VRTSofcore/logs/dnhypervisor.log HyperScale MQ service logs on
the data node.
/var/log/HyperScale.log

Data node storage service logs.

/var/log/ofbud.log

Information used to
troubleshooting the HyperScale
bud service.

Table 8-5
Log file

External storage provider and NetBackup logs
Contents

/var/opt/VRTSofesp/logs/hyperscale-esp.log Logs each export or import
operation initiation request.
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Table 8-5

External storage provider and NetBackup logs (continued)

Log file

Contents

/var/opt/VRTSofesp/logs/Export_ID/export.log Detailed information on export
job Export_ID.
/var/opt/VRTSofesp/logs/Import_ID/export.log Detailed information on import
job Import_ID.
media server FQDN_esp_add.log

Logs the progress of registering
the NetBackup Media Server with
HyperScale.

Synchronizing data node reflection after a failure
A HyperScale data node ensures resiliency by writing its data to another (secondary)
data node. This process is called reflection. HyperScale supports up to two data
nodes.
For a virtual disk (vDisk) that has the Silver flavor or above, data is reflected from
primary data node to secondary data node. In this configuration, if one of the data
nodes fail, the reflection breaks, and the vDisk goes into a resiliency degraded
state. All the requests are now served from a single data node, and there is only
one copy of the data.
This issue can occur in the following situations:
■

The vDisk's primary data node fails.

■

The secondary data node fails.

To resolve this issue, you must add a new data node in place of the one that failed.
Then, restore reflection by synchronizing the new data node with the active data
node. The information on the new data node is brought up to date.
To synchronize data node reflection

1

2

Remove the data node that failed and do one of the following:
■

Add a new data node with a different IP address.

■

Recover the failed data node and add it back with a different IP address.

Start data node synchronization. On the primary data node, enter the following
command:
hypercale restore-dn-refl new_data_node_public_ip_address

This command does the following:
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■

It recovers any existing snapshots from all the degraded vDisks to the new
data node.

■

It restores resiliency to the new data node for all the vDisks that are in a
degrade state.

When the synchronization finishes, the degraded states of all the degraded
vDisks are cleared. The reflection of the Disk's is enabled, and the newly added
data node serves as the secondary data node.

Handling a data node failure due to a disk fault
In the case of a storage failure, the data node goes into the down state. The
secondary data node serves the snapshot or episodic data synchronization read
or write request. To bring up the failed data node again, use the following procedure.
To handle a data node failure due to a disk fault

1

Remove the data node.
See “Removing a data node” on page 19.

2

Remove or replace the failed disk, depending on the storage failure you
encounter.

3

Add the data node again. You can specify a new disk or the same disk as
before.
See “Adding a data node” on page 14.
This operation deletes all the data on the remaining disks, and a new data
node starts.

Recovering a compute node after a storage media
failure
In case of solid-state drive (SSD) or hard disk drive (HDD) storage media failure
(SMF) on a compute node, HyperScale provides storage resiliency for the instances
running on that compute. The applications running on the instances do not
experience any timeout or errors.
The following sequence of events describes how HyperScale provides storage
resiliency in such a scenario:
■

HyperScale detects a storage issue when instance I/Os begin to fail.

■

The Controller detects these failures and immediately redirects the instance I/O
requests to the designated reflection targets.
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The compute node that served as the reflection target now becomes the new
source for the instances.
■

The Controller initiates the restoration of reflection (ROR) workflow to restore
the reflection factor. The Controller selects alternate compute nodes as new
reflection targets for the instances. The reflection targets reside on a single
compute node or across multiple alternate computes, depending on the available
compute nodes and workload distribution in the configuration.

■

The original compute node where the instances were running is not considered
as a potential reflection target because of the storage media failure. The compute
node is alive and running but is not capable of providing full storage resiliency
to instances that are running on it. It is therefore considered to be in a "degraded"
state.

Depending on the type of media failure, one or more of the following alerts are
displayed in Horizon (HyperScale > Overview > Alerts/Events):
SSD I/O error on <computenodename>.
Use vxdisk list command to know the failed SSDs.
I/O error occurred on vdisk associated with compute <computenodename>.
Use vxdisk list command to know the failed HDDs.

Similar failure messages may also appear in the Controller log file.
Perform the following steps to recover the compute node from a media failure:
1.

Perform a live migration of the instances from the affected compute node to
an alternate active compute node where HyperScale is enabled.
See “Performing a live migration” on page 70.

2.

Remove the affected compute node from the HyperScale configuration.
See “Disabling HyperScale on a compute node” on page 23.

3.

Resolve the storage media failure issue.

4.

Add the compute node that you removed earlier in step 2, back in to the
HyperScale configuration.
See “Enabling HyperScale on a compute node” on page 20.
The compute is ready to host instances after you enable HyperScale on it. All
the relevant storage media failure alerts are automatically cleared from the
Horizon user interface.

Troubleshooting
Handling controller node reboot failures

Handling controller node reboot failures
Controller reboot is not fully supported in this release. If the controller node is
restarted, the controller may go in to an unpredictable state.
The HyperScale services may not start in the correct order and the HyperScale
storage driver may fail to register with the Cinder service. As a result, instance
creation may fail due to storage errors.
Use the get-workflows-in-progress API to determine whether or not the
controller node is ready for a reboot
Run the following command on the controller node and observe the command
output:
# hyperscale get-workflows-in-progress

If the command output is TRUE, it indicates that there is at least one workflow in
progress and the controller should not be restarted.
If the command output is FALSE, it indicates that there is no active workflow in the
pending state and the controller can safely be restarted.

HyperScale nodes status shows as up even if one
or more OpenStack services are down
HyperScale does not immediately detect if any of the OpenStack services, such as
the compute service (nova compute) or the block storage service (cinder-volume),
are down. The HyperScale nodes status shows as up in both the user interface and
the command line (hyperscale nodes). The status of the nodes does not change
even in case any of the dependent services are down.
While this does not block any configuration tasks, there may be failures eventually
during the actual execution of operations such as live migration or storage and
image management tasks.
Workaround: While troubleshooting HyperScale issues, as a general guideline,
the first step is to verify that all the OpenStack services are up and running.
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This chapter includes the following topics:
■

Vendor registration commands

■

Regular expression (regex) policy commands

■

Instance snapshot and restore from snapshot commands

■

Export and import commands

■

Backup and restore commands

Vendor registration commands
This section describes commands for registering an external storage provider or
backup vendor with HyperScale and displaying information about the vendor.

vendor-add
Installs the Veritas HyperScale external storage provider on the external node.
Usage
hyperscale vendor-add <servername> <pwd> <openstackpwd> <vendor_type>
<export_path>

Arguments

Command reference
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Positional argument

Description

<servername>

The vendor server name/fully qualified domain name.
If the vendor type is NetBackup, specify the NetBackup Media
Server name/fully qualified domain name.
If the vendor type is HyperScaleESP, specify the storage
server/fully qualified domain name.

<pwd>

Vendor server's root user password.

<openstackpwd>

The OpenStack password.

<vendor_type>

A supported vendor type. Either NetBackup or
HyperScaleESP.

<export_path>

The path on the HyperScale external storage provider where
exported snapshots will be stored.

vendor-by-id
Gets vendor information from the ID registered with HyperScale.
Usage
hyperscale vendor-by-id <vendorid>

Positional argument

Description

<vendorid>

The vendor ID.

vendor-clear
Clears vendor details.
Usage
hyperscale vendor-clear <register_id>

Positional argument

Description

<register_id>

You must provide the register ID.

vendor-list
Lists all vendors registered with HyperScale.
Usage
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hyperscale vendor-list [--status <status>]

Optional argument

Description

--status <status>

The vendor register status.

vendor-remove
Uninstalls the Veritas HyperScale external storage provider from the external node.
Usage:
hyperscale vendor-remove <servername> <pwd> <openstackpwd> <register_id>

Positional argument

Description

<servername>

The vendor server name/fully qualified domain name.
If the vendor type is NetBackup, specify the NetBackup Media
Server name/fully qualified domain name.
If the vendor type is HyperScaleESP, specify the storage
server/fully qualified domain name.

<pwd>

Vendor server's root user password.

<openstackpwd>

The OpenStack password.

<register_id>

The registration ID.

Regular expression (regex) policy commands
This section describes the commands used to work with backup policies.

backup-images-by-policy
List available backup images for a NetBackup backup policy.
Usage
hyperscale backup-images-by-policy [--mode <mode>]
[--fetch_all_images <fetch_all_images>]
<policy_name>

Positional argument

Description

<policy_name>

The NetBackup backup policy name.

Command reference
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Optional argument

Description

--mode <mode>

To be set to <simulator> if you are working with the
NetBackup simulator. Default=<real>.

--fetch_all_images
<fetch_all_images>

Fetch all backup images; that is, backup images belonging
to instances of different HyperScale installations.
Default=False.

backup-policy-list
Get the list of HyperScale policies available from the backup vendor registered with
this HyperScale installation.
Usage
hyperscale backup-policy-list [--mode <mode>] function

Optional argument
--mode <mode>

To be set to <simulator> if you are working with NetBackup
simulator. Default=<real>.

policy-regex-clear-all
Clear all policy regular expressions.
Usage
hyperscale policy-regex-clear-all

policy-regex-create
Assign policy regex.
Usage
hyperscale policy-regex-create <name> <query>

Positional argument

Description

<name>

Policy name.

<query>

Policy query; for example, "{'name':'name contains by VM',
'status':'active'}".
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policy-regex-get
Get policy regular expression.
Usage
hyperscale policy-regex-get <name>

Positional argument

Description

<name>

Policy name.

policy-regex-get-result
Get the policy regex result ad list of virtual machines
Usage
hyperscale policy-regex-get-result <name>

Positional argument

Description

<name>

Policy name.

policy-regex-remove
Remove a policy regex.
Usage
hyperscale policy-regex-remove <name>

Positional argument

Description

<name>

Policy name.

policy-regex-update
Update a policy regex.
Usage
hyperscale policy-regex-update <name> <query> <status>

Positional argument

Description

<name>

Policy name.
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Positional argument

Description

<query>

Policy query; for example, "{'name':'name contains by VM',
'status':'active'}".

<status>

Policy status; for example, assigned or unassigned.

Instance snapshot and restore from snapshot
commands
This section describes commands for creating instance snapshots and restoring
them.

instancesnapshot-create
Initiate an instance-level user snapshot. It contains snapshot(s) of vDisks and
instance metadata.
Usage
hyperscale instancesnapshot-create <Instance ID> <Snapshot Name>

Argument

Description

<Instance ID>

The instance ID of the instance for which snapshot is to be
created.

<Snapshot Name>

The name to give the snapshot.

instancesnapshot-list
List user-created snapshots.
Usage
hyperscale instancesnapshot-list [--all-tenants [<0|1>]]
[--instance-id <instance-id>]
[--snapshot-type <snapshot-type>]

Optional argument

Description

--all-tenants [<0|1>]

Shows details for all tenants. Only the HyperScale
infrastructure administrator can specify this option.

--instance-id <instance-id>

Filters list by a instance ID. Default=None.
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Optional argument

Description

--snapshot-type
<snapshot-type>

Filters list by snapshot type <User|Bkup|All>. Default=User.

instancesnapshot-restore
Initiate the user snapshot restore operation.
Usage
hyperscale instancesnapshot-restore <InstanceSnapId> <NewVmName>

Positional argument

Description

<InstanceSnapId>

The instance snapshot ID.

<NewVmName>

The name to be given to the new instance.

instancesnapshot-delete
Delete a user snapshot.
Usage
hyperscale instancesnapshot-delete <InstanceSnapId>

Argument

Description

<InstanceSnapId>

The instance snapshot ID.

instancesnapshot-query
Query the status of a user-initiated snapshot.
Usage
hyperscale instancesnapshot-query <InstanceSnapId>

Argument

Description

<InstanceSnapId>

The instance snapshot ID.

Export and import commands
This section describes commands for exporting and importing snapshots.
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instancesnapshot-create-n-export
Take a new instance snapshot and initiate its export.
Usage
hyperscale instancesnapshot-create-n-export <Instance ID> <SnapshotName>

Argument

Description

<Instance ID>

The instance ID of the instance for which snapshot is to be
created and exported to the registered external storage.

<Snapshot Name>

The name to give the snapshot to be exported.

instancesnapshot-export-a-copy
Exports a copy of an existing instance snapshot to the registered external storage
provider.
Usage:
hyperscale instancesnapshot-export-a-copy <Snapshot ID>

Argument

Description

<Snapshot ID>

The snapshot ID of the instance snapshot.

instancesnapshot-export-image-delete
Delete the exported image of a snapshot from the HyperScale external storage
provider.
Warning: Exercise caution. You cannot reverse this action.
Usage
hyperscale instancesnapshot-export-image-delete <objectid> <ExportId>

Argument

Description

<objectid>

The instance's HyperScale ID.

<ExportId>

The export ID.

Command reference
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instancesnapshot-export-images-by-object-list
List the exported images for an instance.
Usage
hyperscale instancesnapshot-export-images-by-object-list <objectid>

Argument

Description

<objectid>

The instance's HyperScale ID.

instancesnapshot-export-images-list
List all the exported images.
Usage
hyperscale instancesnapshot-export-images-list
[--fetch_all_images <fetch_all_images>]

Argument

Description

--fetch_all_images
<fetch_all_images>

Lists all the exported images.

instancesnapshot-export-job-delete
Purge the instance snapshot export job from HyperScale.
Usage
hyperscale instancesnapshot-export-job-delete

Argument

Description

<ExportId>

The export ID.

instancesnapshot-export-job-list
List the instance snapshot export jobs that are in progress, completed, or failed.
Usage
hyperscale instancesnapshot-export-job-list [--all-tenants [<0|1>]]
[--instance-id <instance-id>]
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Argument

Description

--all-tenants [<0|1>]

Shows details for all tenants. Only the HyperScale
infrastructure administrator can use this argument.

--instance-id <instance-id>

Filters the list by an instance ID. Default=None.

instancesnapshot-export-job-query
Query the status of a snapshot export job.
Usage
hyperscale instancesnapshot-export-job-query <ExportId>

Argument

Description

<ExportId>

The export ID.

instancesnapshot-import
Launch a new instance (also known as an import) from an exported snapshot.
Usage
hyperscale instancesnapshot-import [--hyperscale_id <hyperscale_id>]
[--target_tenant_id <target_tenant_id>]
[--network-id <network_id>]
<export_id> <new_instance_name>
<exp_jobid> <instance_id>
<src_tenant_id>

Positional arguments

Description

<export_id>

The export ID.

<new_instance_name>

The name of the new instance.

<exp_jobid>

The export job ID.

<instance_id>

The VM ID of the backed up instance.

<src_tenant_id>

The instance's tenant ID at the time of export.

Optional argument

Description

--hyperscale_id <hyperscale_id>

The HyperScale installation ID at the time of export.
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Optional argument

Description

--target_tenant_id <target_tenant_id>

The target project or tenant ID. The default is
src_tenant_id. However, it must be provided if the
source tenant does not exist.

--network-id <network_id>

The network ID. You must specify this argument
if the current network configuration is different than
the backup network configuration.
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instancesnapshot-import-job-delete
Purge the import job/task from HyperScale.
Usage
hyperscale instancesnapshot-import-job-delete <restoreid>

Positional argument

Description

<restoreid>

The restore ID.

instancesnapshot-import-job-list
List the import jobs that are in progress, completed, or failed for an instance.
Usage
hyperscale instancesnapshot-import-job-list [--instance-id <instance_id>]

Optional argument

Description

--instance-id <instance_id>

Filters list by an instance ID. Default=None.

instancesnapshot-import-job-query
Query the status of an import job.
Usage
hyperscale instancesnapshot-import-job-query <import_id>

Positional argument

Description

<import_id>

The import ID.
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Backup and restore commands
This section describes commands for backing up and restoring resources.

backup-count
Get the number of backups for a given resource.
Usage
hyperscale backup-count <resource_id> <resource_type>

Positional argument

Description

<resource_id> resource id <instance_id The resource ID.
| compute_id | datanode_id>
<resource_type> resource type <vm |
compute | datanode>

The resource type.

backup-images-by-object
List the available backup images for an instance.
Usage
hyperscale backup-images-by-object [--mode <mode>] <objectid>

Positional argument

Description

<objectid>

The instance's HyperScale ID.

Optional argument

Description

--mode <mode>

Set to <simulator> if you are working with the NetBackup
simulator. Defult=<real>.

backup-images-by-policy
List the available backup images for a NetBackup backup policy.
Usage
hyperscale backup-images-by-policy [--mode <mode>]
[--fetch_all_images <fetch_all_images>]
<policy_name>
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Positional argument

Description

<policy_name>

NetBackup backup policy name.

Optional argument

Description

--mode <mode>

Set to <simulator> if you are working with NBU simulator.
Defult=<real>.

--fetch_all_images
<fetch_all_images>

Fetch all backup images from all HyperScale installations.
Default=False

backup-job-delete
Purge the backup job/task from the HyperScale task list.
Usage
hyperscale backup-job-delete <backupid>

Positional argument

Description

<backupid>

The backup ID.

backup-job-query
Query the status of a backup job.
Usage
hyperscale backup-job-query <backup_id>

Positional argument

Description

<backup_id>

The backup ID.

backup-jobs-by-object-list
List the backup jobs/tasks in progress, completed, or cancelled for given instance.
Usage
hyperscale backup-jobs-by-object-list <objectid>

Positional argument

Description

<objectid>

The HyperScale object ID of the instance.
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backup-jobs-list
List all the backup jobs/tasks in progress, completed, or cancelled.
Usage
hyperscale backup-jobs-list [--all-tenants [<0|1>]]

Optional argument

Description

--all-tenants [<0|1>]

Displays details for all tenants. Only the HyperScale
infrastructure administrator can specify this argument.

backup-policy-list
Get the list of HyperScale policies available from the backup vendor registered with
this HyperScale installation.
Usage
hyperscale backup-policy-list [--mode <mode>]

Optional argument

Description

--mode <mode>

Set to <simulator> if you are working with the NetBackup
simulator. Default=<real>.

backup-status-show
Get the status of the backup job/task.
Usage
hyperscale backup-status-show <backupid>

Positional argument

Description

<backupid>

Backup ID

get-esp-status
Get the status of the backup node-add operation.
Usage
hyperscale get-esp-status <backup-ip>
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Positional argument

Description

<backup-ip>

The management IP of the backup host added.

restore
Initiate a restore operation from a backup image.
Usage
hyperscale restore [--hyperscale_id <hyperscale_id>]
[--target_tenant_id <target_tenant_id>]
[--network-id <network_id>] [--mode <mode>]
<backupid> <newvmname> <bkp_jobid> <backedup_date>
<backedup_time> <policy> <instance_id>
<src_tenant_id>

Positional argument

Description

<backupid>

The backup ID.

<newvmname>

The new instance name.

<bkp_jobid>

The backup job ID.

<backedup_date>

The backup_date.

<backedup_time>

The backup_time.

<policy>

The backup policy name.

<instance_id>

VM ID of the backed up instance.

<src_tenant_id>

The tenant ID at the time of the backup.

Optional argument

Desceiprion

--hyperscale_id
<hyperscale_id>

The HyperScale installation ID at the time of the backup.

--target_tenant_id
<target_tenant_id>

The target tenant ID. Default: <Same tenancy as when
backed up.> However, it must be provided if the source tenant
does not exist.

--network-id <network_id>

The network ID. It must be specified if the current network
configuration is different than the backup.

--mode <mode>

Set to <simulator> if you are working with NetBackup
simulator. Default=<real>.
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Managing instances
This chapter includes the following topics:
■

Launching an instance from an exported snapshot

■

Attaching a snapshot to a different virtual machine

■

Recovering a data volume to an earlier state

■

Restoring an instance from a backup

Launching an instance from an exported snapshot
You can launch a new instance from an instance snapshot that was previously
exported. This allows you to put an instance into service quickly without specifying
new configuration values. This task can also be performed by the HyperScale
infrastructure administrator.
See “Launching an instance from an exported snapshot” on page 33.

Attaching a snapshot to a different virtual machine
When you attach a snapshot to its parent virtual machine, that process is called
recovery. When you attach the snapshot to the different virtual machine, the process
is called off-hosting storage. To off-host storage, you need the following:
■

A Linux virtual machine and a data volume that is attached to it

■

Data on the volume and storage added

To attach a snapshot to a different virtual machine

1

Navigate to Project > Compute > Volumes.

2

In the Volumes table, click the name of the volume you want to recover.
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3

On the Volume Details page, click the Version List tab. This tab lists the
available snapshots.

4

Select the Version Timeline tab. This tab lists the snapshots for that volume,
beginning with the latest one.

5

Click the name of the snapshot you want to attach.

6

On the Attach Snapshot dialog box, use the VM drop-down list to select the
virtual machine to which the snapshot will be attached. Make sure that this
virtual machine is different from the parent virtual machine.

7

Click Attach.

8

Verify that the snapshot was attached successfully. Navigate to Project >
Compute > Instances.

9

Click the instance name to which you attached the snapshot.

10 Click the Console tab.
11 In the virtual machine console, use a tool like md5sum to verify the integrity of
the data.

Recovering a data volume to an earlier state
If an application fails, you can use HyperScale to recover a data volume from
snapshot to an earlier state.
To perform this task, you need the following:
■

A Linux virtual machine, and a virtual machine that is configured with the Silver
flavor (VTRSSilver) or above.

■

A data volume that is attached to the virtual machine.

■

Data on the data volume (or added storage). By default, a snapshot is created
every 15 minutes. Wait 20 minutes to make sure that the snapshot is created
before you complete the following steps.

To recover a data volume to an earlier state

1

Navigate to Project > Compute > Volumes.

2

In the Volumes table, click the name of the volume you want to recover. (The
virtual machine must have the Silver flavor or above.)

3

On the Volume Details page, click the Version List tab. This tab lists the
available snapshots.

4

Select the Version Timeline tab. This tab lists the snapshots for that volume,
beginning with the latest one.
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5

Click the name of the snapshot you want to attach.

6

On the Attach Snapshot dialog box, use the VM drop-down list to select the
virtual machine to which the snapshot will be attached. Be sure to select the
same parent virtual machine.

7

Click Attach.

8

Verify that the snapshot was attached successfully. Navigate to Project >
Compute > Instances.

9

Click the instance name to which you attached the snapshot.

10 Click the Console tab.
11 In the virtual machine console, use a tool like md5sum to verify the integrity of
the data.

Restoring an instance from a backup
You can restore an instance from a backup. The HyperScale infrastructure
administrator can also perform this task.
See “Restoring an instance from a backup” on page 48.

99

Chapter

11

Exporting and restoring
virtual machines
This chapter includes the following topics:
■

Monitoring export progress on the user interface

■

Restoring data to a virtual machine

■

Taking and restoring instance snapshots

Monitoring export progress on the user interface
The external storage provider takes instance snapshots and backs up the instance
snapshot once it becomes available. After the export, snapshot is deleted.
If there are multiple instances to be exported, they are snapshotted and exported
one after another. As soon as a snapshot is taken of an instance for export, the
export process for the instance starts.
You can monitor the progress of an export on the instance time line tab (Admin >
Instance > Timeline). When the export process begins, the new export job is
displayed in the export time line in the Creating state. You see a rotating hourglass.
When the export completes, the Creating icon changes to one of the following:
■

Complete (a tick mark icon)

■

Failed (a cross)

The exports remain in the system until they are purged from the external storage
provider.
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Restoring data to a virtual machine
You can restore virtual machine data and other information (including the virtual
machine's flavor and network) from export. You initiate the restore process from
the virtual machine's version time line.
When you click on an export icon, a dialog box is displayed with the Restore to
new option. This option creates a new virtual machine using the data and
configuration that is restored from the export. When you start the restore operation,
new virtual disks are created and the external storage provider restores data in 1
GB chunks on to these newly created vDisks.
To restore data to a new virtual machine

1

Create new vDisks in HyperScale, one for every vDisk present in the export.

2

Restore the data from the export onto the new vDisks

3

Restore configuration information. The configuration consists of the following
parts:

4

■

The virtual machine's flavor information including the amount of RAM, disk
size, virtual CPUs, HyperScale specifications, and so on.

■

The virtual networks that are associated with the virtual machine.

Check if flavor information has changed since an export was performed. Do
one of the following:
■

If the flavor has not changed, use the flavor that is present in the system
to boot the new virtual machine.

■

If the flavor has changed, create a new flavor from the information that is
captured during the export.

5

The network that is associated with the virtual machine when the export was
initiated should be present when the restore in performed. If the same network
is not found, launching the virtual machine fails.

6

Look at the newly created disks and determine which one is the boot disk.

7

Boot the new virtual machine using the boot disk and flavor, and network
information.

8

Attach the other disks that are restored from the export.
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Taking and restoring instance snapshots
When you trigger and instance snapshot, HyperScale executes a snapshot of the
instance's vDisk and captures all the snapshot information and configuration
information.
When you restore an instance from a snapshot, HyperScale creates a new instance
using the information it captures in the instance snapshot metadata. Internally, the
instance snapshot functionality detects if the qemu guest agent is configured for a
virtual machine instance. If it is, HyperScale performs application/filesystem
consistent snapshot of all the vDisks attached to the instance. If the qemu guest
agent is not configured, HyperScale performs a crash consistent snapshot of the
attached vDisks.
To perform an instance snapshot

1

To start the snapshot, do one of the following:
■

On the Project > Compute > Instances page, select Create Snapshot.

■

One the HyperScale command line, enter the following:
# hyperscale-instancesnapshot create

2

On the user interface or command line, enter the instance snapshot name.
HyperScale does the following:
■

If you have configured the qemu guest agent within the instance, HyperScale
performs a guest application/file system consistent snapshot of the vDisk.

■

If qemu quest agent is not configured within the instance, HyperScale
performs a crash consistent snapshot of the vDisk.

■

A snapshot for all the attached vDisk is performed and listed on the Project
> Compute > Volumes > Volume Snapshots tab. The name of volume
snapshot is the same as the instance snapshot name.

■

When all the volume snapshots are marked available, the instance snapshot
is marked as available.

■

The instance snapshot is listed on the instance version time line and on
the Project > Compute > Images page.

■

You can also list the instance snapshot can also be listed using the following
command:
hyperscale-instancesnapshot list
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To restore a virtual machine from an instance snapshot

1

When you trigger a restore of an instance snapshot, HyperScale creates new
volumes from the snapshot volumes.

2

Launch a new instance using the boot disk and configuration within the instance
snapshot metadata.
Note: The network associated with the instance at the time of snapshot should
be present at the time the instance is create. If it is not, the instance fails when
you try to launch it

3

Attach all the data disk to the new instance.
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