Video Screencast Help

Spreadsheet archiving bug (numeric items are not converted)

Created: 22 Jul 2013 | 1 comment
Mx's picture
2 Agree
0 Disagree
+2 2 Votes
Login to vote

A customer recently escalated an issue whereby they were unable to search for numeric fields in archived spreadsheets. When runninng searches for numeric patterns they knew to be stored in a particular spreadsheet the results did not contain the spreadsheet in question. Further investigation revealed that numeric fields were not converted by the archiving engine. After speaking to Symantec I was explained that as a workaround I could set reg key "HKLM\SOFTWARE\KVS\Enterprise Vault\ConvertExcelToText" to zero to prevent EV from converting spreadsheets to text.

There are two problems with this approach:

1) It does not work retrospectively (it doesn't apply to spreadsheets already converted)

2) The reason why the  "HKLM\SOFTWARE\KVS\Enterprise Vault\ConvertExcelToText" key is set to one by default is to prevent large spreadsheets from affecting the archiving performance. Disabling that may result in performance issues.

According to Symantec, numeric fields will not be converted if the ConvertExcelToText key is enabled. Ideally this behaviour should be changed so that numeric fields are also converted and therefore searcheable.  

Comments 1 CommentJump to latest comment

Ben Watts's picture

I appreciate that some Excel documents can be huge but this is something, in my opinion, that should definitely be the norm.

Obviously one way to work around that retrospective aspect is to rebuild the index for the affected archive, obviously not ideal but it will index the items with the new settings.

Login to vote